Segmentation fault in Widelands::Soldier::attack_update (this=0x99f1ea0, game=..., state=...) at src/logic/soldier.cc:1003

Bug #1208229 reported by Hans Joachim Desserud on 2013-08-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
cghislai

Bug Description

I don't exactly know how to reproduce this, but here's what I did:
Started a new multiplayer game on Impact as spectator with three aggressive AIs, Barbarian, Empire and Atlantean, respectively. Game type Autocrat in case it matters.
Sped up the game to 65.5x and watch the game progress.
After a long time (when the players had each met each other and conquered a bit of each others land, so fighting in general seem to work), the game suddenly crashed with this segfault.

I think I've seen this issue at least twice, but I have no idea what exactly is triggering it.
I've attached a stack trace, if there's any more information I can provide or get from gdb which would be useful let me know. The replay only tells me "REPLAY: Caught exception Stream ended unexpectedly (0 bytes read, 1 expected)". I'll experiment a bit with autosaving and see if that might provide something useful.

Widelands r6695 on Ubuntu 13.04.

Hans Joachim Desserud (hjd) wrote :
cghislai (charlyghislain) wrote :

Thanks! I reproduced this using your explanations. I will commit a fix

Changed in widelands:
status: New → Confirmed
assignee: nobody → cghislai (charlyghislain)
cghislai (charlyghislain) wrote :

Fixed in 6700. It used to happen when a soldier won a fight around a newly conquered site when his former one was destroyed in between.

Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments