Pausing during save dialog behaves different in replays and games

Bug #1206917 reported by wl-zocker on 2013-07-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Low
cghislai

Bug Description

In normal games, the speed is just set to "Pause (1x)" (or whatever) when the save dialog is opened. After it is closed, the game continues at the speed it was before.
In replays, the speed is set to "0x" (which is also pausing), but the information what it was before (e.g. 2x) is lost. After the dialog is closed, the game therefore stays at speed 0x, which has to be increased manually to the old value.
I think it should behave the same way in both cases. I prefer the way it is in normal games because it is more intuitive (pause automatically, continue automatically).

Related branches

cghislai (charlyghislain) wrote :

I also add that closing the dialog with right click does not restore the speed.

Changed in widelands:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → cghislai (charlyghislain)
milestone: none → build18-rc1
Changed in widelands:
status: Confirmed → In Progress
Changed in widelands:
status: In Progress → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers