Endless loop in Layout::fit_nodes

Bug #1206712 reported by cghislai on 2013-07-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

While testing the chat overlay using the new renderer, i noticed the game hangs if i try to enter a very long single-word string in the chat box, like "mmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmmm". I called the render method with a maximum width, and my guess is that the renderer is stuck while trying to find a breakpoint.

In the while (m_idx < m_all_nodes.size()) loop, m_idx keeps a value of 47 (out of 49), skipping all the the checks and going over again.

Related branches

SirVer (sirver) wrote :

does the loop terminate eventually? This is quite a bad bug :/.

Changed in widelands:
importance: Undecided → High
status: New → Incomplete
milestone: none → build18-rc1
cghislai (charlyghislain) wrote :

Nope, the loop is stuck.

Changed in widelands:
status: Incomplete → Confirmed
cghislai (charlyghislain) wrote :

I put a fix in the fh1 branch

SirVer (sirver) wrote :

This should be backported to trunk today.

SirVer (sirver) wrote :

I backported this today.

Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
SirVer (sirver) wrote :

The fix for this bug changed the correctness of the rich text rendering. I fixed in my move_tests branch.

SirVer (sirver) on 2014-07-05
Changed in widelands:
importance: High → Medium
status: Fix Released → In Progress
milestone: build18-rc1 → build19-rc1
GunChleoc (gunchleoc) wrote :

It this fixed now?

kaputtnik (franku) on 2016-07-05
Changed in widelands:
status: In Progress → Triaged
GunChleoc (gunchleoc) wrote :

I have tested this again and the FPS does go down a bit, but that might also be due to long calculations, because the FPS will recover.

I would like to see the original fix that changed the correctness, and also the final fix in the move_tests branch - I can't find the branch. Or is this now all in trunk anyway?

kaputtnik (franku) wrote :

I played a longer game with janus and couldn't find any delay when entering such long strings.

So i think this bug is fixed somehow. Feel free to reopen it again

Changed in widelands:
status: Triaged → Fix Committed
GunChleoc (gunchleoc) on 2016-10-25
Changed in widelands:
status: Fix Committed → Fix Released
GunChleoc (gunchleoc) wrote :

Fixed in build19-rc1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers