Autosave leads to crash on replays

Bug #1206441 reported by wl-zocker on 2013-07-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
High
cghislai

Bug Description

tested with r6880.

Steps to reproduce:
- Set the autosave interval to 1 minute.
- Watch the replay of any game.

After one minute of real time, Widelands crashes (game speed does not influence the time). The stdout says "Autosave: interval elapsed (60 s), saving".

I think autosave in replays is not necessary and should not take place.

Related branches

cghislai (charlyghislain) wrote :

I agree that autosave may not be required for replays. But since saving during replay is allowed, the crash should not occur.

cghislai (charlyghislain) wrote :

This due to the absence of any chat provider.
 Should I disable autosaving in replays as well?

Changed in widelands:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → cghislai (charlyghislain)
milestone: none → build18-rc1
Changed in widelands:
status: Confirmed → In Progress
SirVer (sirver) wrote :

Yes, disable autosaving in replays. Make limited sense anyways.

cghislai (charlyghislain) wrote :

I removed the last link. The proper implementation for the savehandler will be done in the log_message branch. A few branches have changes in this file, so there will be conflicts... I will resolve them when branches get merged

Changed in widelands:
status: In Progress → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers