"Follow" function in watch window crashes in replays or when playing as a spectator

Bug #1206211 reported by wl-zocker on 2013-07-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
cghislai

Bug Description

I guess the title says it all. Tested in r6880, no useful output in stdout.

I do not know if related, but when I follow a worker via that feature in a normal game, the watch window seems to "hang" for short moments. This is not the case in the main window.

Related branches

Hans Joachim Desserud (hjd) wrote :

Thanks for noticing and reporting this issue.

I am also able to trigger this when playing a multiplayer game as spectator, and the error message does indeed indicate this could be the reason:
Program received signal SIGSEGV, Segmentation fault.
0x0000000000ac56df in Interactive_Player::player (this=0x0) at /home/user/widelands/src/wui/interactive_player.h:68
68 return game().player(m_player_number);

I believe there should be a stderr file in the same place as stdout on Windows, so you might want to check that for more information in the future. :)

Changed in widelands:
importance: Undecided → Medium
milestone: none → build18-rc1
status: New → Confirmed
tags: added: regression
summary: - "Follow" function in watch window crashes in replays
+ "Follow" function in watch window crashes in replays or when playing as
+ a spectator
tags: added: multiplayer
wl-zocker (wl-zocker) wrote :

There is indeed a stderr file, but it is always empty (I check it immediately after the crash). I do not know when something gets written there.

SirVer (sirver) wrote :

Is it positive that this is a regression? I mean could it not be that this was already in b17?

wl-zocker (wl-zocker) wrote :

In b17, the game crashes as soon as I click "follow" (specatator in multiplayer game).

tags: removed: regression
cghislai (charlyghislain) wrote :

My guess is that the code assume interactive_player is not null.

wl-zocker (wl-zocker) wrote :

Since one can follow wild animals and even the enemies' workers, I do not understand why an interactive player is needed. It would be nice to have that feature, e.g. in a replay I wanted to follow a ship making an expedition. If that is not possible (for whatever reason), the button should be greyed out to prevent the game from crashing.

SirVer (sirver) wrote :

I agree that this should be possible - it is even more useful when you are observer or watching a replay then when you are not. I agree with charlys assessment too.

Changed in widelands:
assignee: nobody → cghislai (charlyghislain)
Hans Joachim Desserud (hjd) wrote :

>Is it positive that this is a regression?
>In b17, the game crashes as soon as I click "follow" (specatator in multiplayer game).

Ok, not sure what happened or if I did something wrong but when I tried it in b17 I didn't get it to crash. I am perfectly able to reproduce the crash in b17 now though, so it is not a regression. Sorry about that.

Changed in widelands:
status: Confirmed → In Progress
Changed in widelands:
status: In Progress → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers