Fisher produces fish without decreasing resources

Bug #1205457 reported by Jens Beyer on 2013-07-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Undecided
cghislai

Bug Description

Open a new game Checkmate, build a new fisher in the lower part.

The fisher will probably head "west" and do his work. Observe closely the flag where he works.

After he is done and on his way back, pause the game and observe (debug window)
- the flag where he fished
- all the places in distance 1 (of course, especially on the sea and shore)

You will notice that he will most probably carries a fish to his hut (which he drops then at the flag), but all spots still are full of fish.

Related branches

Changed in widelands:
status: New → Confirmed
cghislai (charlyghislain) wrote :

This is because he is fishing way further. The mapregion was not reseted between the two loops.

Changed in widelands:
assignee: nobody → cghislai (charlyghislain)
milestone: none → build18-rc1
Changed in widelands:
status: Confirmed → In Progress
Changed in widelands:
status: In Progress → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers