Buildings and building statistics have different color groups for productivity

Bug #1204199 reported by Hans Joachim Desserud on 2013-07-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Low
Unassigned

Bug Description

Steps to reproduce:
1. Build a building.
2. Open Statistics -> Build statistics and select the building in question.
3. Press C and S to display building names and productivity.
4. Speed up the game and pay attention to the productivity and color codes used for the building and in the statistics window.

Expected result:
They should be consistent and display the same color.

Actual result:
The statistics window switch from red to yellow when it reaches 15% and from yellow to green after reaching 55%. The building text just assigns the colors to each third (ie. red between 0 and 33, yellow between 34 and 67, and the rest is green).

Fwiw, my personal favorite is the latter, as I think that makes more sense.

I think I've wondered if this might be the case earlier, so this is likely an older issues. Though after the recent improvements from bug 580905 it is now a lot more visible.

Widelands r6655

Related branches

Changed in widelands:
status: New → Confirmed
importance: Undecided → Low
milestone: none → build18-rc1
Changed in widelands:
status: Confirmed → Fix Committed
cghislai (charlyghislain) wrote :

I just reopen this one for the mine that don't follow production site conserning the building statistic string

Changed in widelands:
status: Fix Committed → Confirmed
cghislai (charlyghislain) wrote :

Nevermind, it works as intended

Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers