Ingame README needs review

Bug #1203474 reported by Jens Beyer on 2013-07-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

The ingame Readme (which is the file txts/README file) shows some information which might be out of date.

Especially the section about reporting bugs needs overhaul. It speaks about sending a mail to the Sourceforge list instead of the LP Bugtracker, and it does not include the logfiles to be sent with the bug report.

There might be other things...

Related branches

Hans Joachim Desserud (hjd) wrote :

Yes, this should definitely be updated before the next build is released. I was translating parts of it recently, and noticed that some sections look pretty dated.

Changed in widelands:
importance: Undecided → Medium
milestone: none → build18-rc1
status: New → Confirmed
SirVer (sirver) wrote :

Note that when this is touched, it should also be converted to look like a text.lua from the campaign maps, i.e. move over to use lua as description language instead of being a flat file. The same is true for txt/developers, though there we have to make sure that the website branch (which reads this file too) is updated as well.

Hans Joachim Desserud (hjd) wrote :

FYI, parts of the discussion in https://code.launchpad.net/~hjd/widelands/more-stringfixes/+merge/177453 is relevant for the content of these files.

Nasenbaer (nasenbaer) wrote :

I hate to think about certain things too late (which means: when there is already work done and it might be useless).

Anyway: Can anyone (maybe SirVer) explain to me, why the lua format should be prefered for the README, which basically is a simple text?

As far as I understand, Lua would not do anything else but to load the text into memory and send it to the richtext renderer - which would be called in the current state anyways. I obviously must miss something, but I can only see, that an additional Lua complexibility is added to do basically 100% the same... :-/

please enlighten me

SirVer (sirver) wrote :

Yep, I can. The reason the flat text files have to go is that they are written in the old text renderers syntax which is not compatible to the new one. Changing all of them to using Lua's programmatic interface means that we can change the syntax that these Lua methods create once and have it use the new renderer everywhere.

That is why the plain text files have to die: we cannot kill the old rich text rendering system otherwise.

Nasenbaer (nasenbaer) wrote :

@ SirVer (#5):

Okay, thank you :)!

SirVer (sirver) wrote :

I think it should be fixed till tomorrow, because it is super important and we cannot update tagged strings after feature freeze.

SirVer (sirver) wrote :

I look at this soonish and try to merge the related branch and fix the file myself.

Changed in widelands:
assignee: nobody → SirVer (sirver)
Hans Joachim Desserud (hjd) wrote :

I've been very busy lately and haven't had time to work on this.

While we have converted and somewhat tweaked the regular readme, the editor readme has not yet been touched at all. Just now I saw that the merge proposal had been merged, though I guess in order to drop the old editor we would need to fix the editor readme as well...

SirVer (sirver) wrote :

I updated the readme in r6760. The main changes were combining similar paragraphs into one, slight rewording, fixing of outdate information and removing of how to make and play back a session record. This feature has not been useful for a bug report in the last few years and is really only for developers (but I doubt it is useful there too anymore. I see us killing it when moving to SDL 2.0).

Changed in widelands:
status: Confirmed → Fix Committed
assignee: SirVer (sirver) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers