Can't open directory with maps

Bug #1202499 reported by P. van Tillo on 2013-07-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
High
Unassigned

Bug Description

Ubuntu 13.04 64-bits Widelands bzr6629

When I start a new game, I get following

http://members.razcall.com/tukkie/Werkblad%201_009.png

(where there is a white block in front, those are submaps)

Then I click on a game, and I can start playing.

But when I like to open a submap, then I get following error

http://members.razcall.com/tukkie/Werkblad%201_010.png

Later on, when playing a game, into the message menu see

http://members.razcall.com/tukkie/Werkblad%201_011.png

Related branches

P. van Tillo (pvtillo) on 2013-07-18
description: updated
P. van Tillo (pvtillo) on 2013-07-18
description: updated
SirVer (sirver) wrote :

What do you mean by submap?

P. van Tillo (pvtillo) wrote :

Sorry, I mixed the language, (maps = dutch), I mean directories.

Following are directories in my game: Bluebyte, MP Scenarios, Other, Seefaring and Settlermaps.

That are the directories, i mean. If I click on one of these drirectories, I get the message

http://members.razcall.com/tukkie/Werkblad%201_010.png

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting. I get the following error message when I attempt to open one of the map directories:

"Richtext rendering error: Syntax error at 1:62: expected an allowed tag, got 'parent'. String continues with: '<parent></font></p></rt>'"

This is likely caused by bug 1202133, though since it is actually triggering an error message, I'd argue it is different enough. It is also crashing with opengl enabled, which indicates it is a more general problem.

tags: added: map ui
summary: - Can't open submap
+ Can't open directory with maps
Changed in widelands:
status: New → Confirmed
importance: Undecided → High
milestone: none → build18-rc1
tags: added: regression
cghislai (charlyghislain) wrote :

This is indeed related to the use of the new text render for tables.
A general fix is available in the linked branch

SirVer (sirver) on 2013-07-20
Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers