With opengl enabled, screenshots display edges in terrain strangely

Bug #1202146 reported by Hans Joachim Desserud on 2013-07-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Medium
cghislai

Bug Description

Steps to reproduce:
1. Start a new game.
2. Take a screenshot (press f11)
3. Open the stored screenshot (typcally found in ~/.widelands/screenshots/)
4. Observe the image.

Expected result:
The screenshot is an exact replica of what was displayed in the Widelands window at the time it was taken.

Actual result:
Edges and differences in terrain seem to light up as unrendered parts (see attached example)

This only happens when opengl is enabled, screenshots stored with software rendering are fine. If others are not able to reproduce this with opengl enabled, it might be a driver issue I suppose, but please check.

Widelands bzr r6629 on Ubuntu 13.04.

Related branches

Hans Joachim Desserud (hjd) wrote :
Nasenbaer (nasenbaer) on 2013-07-17
Changed in widelands:
status: New → Confirmed
tags: added: opengl
SirVer (sirver) wrote :

Same problem here - looks like some transparency issues. Might be that this is just a thing on how we write the pgm, so I'd start to investigate there. An easy fix might be to flatten the screen surface to RGB (from RGBA) before writing it out.

cghislai (charlyghislain) wrote :

I had a look but couldn't figure out why the terrain dither left non-zero alpha to the screen buffer.
I think we can safely flatten the image as transparent data is useless, or maybe clear the alpha channel before reading pixels.

Changed in widelands:
assignee: nobody → cghislai (charlyghislain)
status: Confirmed → In Progress
SirVer (sirver) on 2013-08-07
Changed in widelands:
status: In Progress → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments