Dialogs (and list of maps) have white background and repetition

Bug #1202133 reported by Hans Joachim Desserud on 2013-07-17
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
widelands
High
Unassigned

Bug Description

Steps to reproduce:
1. Main menu->Single player->New game.
2. Observe the list of maps available.

The map names are repeated multiple times. This is new behaviour, and I suspect it was a pretty recent change.

Widelands bzr r6629

Related branches

Hans Joachim Desserud (hjd) wrote :
Hans Joachim Desserud (hjd) wrote :

Several dialogs now have white background in some places as well as repetition of text too. See screenshot for example.

Furthermore, this only happens if opengl is enabled. (For some reason...)

tags: added: opengl
summary: - Map names repeated multiple times in the list of maps
+ Dialogs (and list of maps) have white background and repetition
cghislai (charlyghislain) wrote :

This is probably related to the change I introduced in tables. I switched to the new font renderer for tables lines, and it looks there are some issues. I can't test opengl without the graphic reset changes, so i didn't spot those, but i found a few minor issues without opengl as well. I'm on it.

Nasenbaer (nasenbaer) on 2013-07-17
Changed in widelands:
status: New → Confirmed
Jens Beyer (qcumber-some) wrote :

Related: It seems there is also an update problem. I noticed it with a building window shortly after a building was constructed. It showed that the worker is coming in... and this notice did not disappear after the worker entered the building. I had to close the game and reload the savegame to make the worker appear in the building window.

Hans Joachim Desserud (hjd) wrote :

Also affects the news window (see duplicate bug 1202133). And likely everywhere else tables are used I suspect...

Changed in widelands:
importance: Medium → High
SirVer (sirver) on 2013-07-20
Changed in widelands:
status: Confirmed → Fix Committed
Hans Joachim Desserud (hjd) wrote :

I can no longer reproduce this issue in r6643. Thanks for a quick fix :)

SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
wl-zocker (wl-zocker) wrote :

Not sure if it is correct to reopen a bug report with "Fix Released", but the very same issue showed up in r6885 (it was fixed in build 18). The same symptoms as described above: repeated strings and several white backgrounds, only when OpenGL is enabled.

Tino (tino79) on 2014-03-18
Changed in widelands:
status: Fix Released → Confirmed
Tino (tino79) wrote :

I think it is ok, you already helped to find the bug/changes which both SirVer and me yesterday couldn't.

But i am not able to determine which of these fixes got disabled by the spritemap merge :/

Changed in widelands:
milestone: build18-rc1 → build19-rc1
SirVer (sirver) wrote :

Found it :). Fix is reintroduce in r6886. Now the interesting question is, is this fixcommitted or fixreleased?

Changed in widelands:
status: Confirmed → Fix Released
milestone: build19-rc1 → none
Hans Joachim Desserud (hjd) wrote :

Thanks for digging up the old report, wl-zocker. :)

>Now the interesting question is, is this fixcommitted or fixreleased?

It was released, but then it came back due to a regression. I'd argue that since a patch was added for this during the build 19 development cycle, it shouldn't be considered released (again) until build 19 is.

SirVer (sirver) wrote :

you are the master of bugs. So be it.

Changed in widelands:
status: Fix Released → Fix Committed
milestone: none → build19-rc1
GunChleoc (gunchleoc) on 2016-10-25
Changed in widelands:
status: Fix Committed → Fix Released
GunChleoc (gunchleoc) wrote :

Fixed in build19-rc1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers