Soldier preference button graphics

Bug #1202040 reported by Teppo Mäenpää on 2013-07-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Widelands media development
Undecided
Unassigned
widelands
Wishlist
Unassigned

Bug Description

Files pics/msite_prefer_heroes.png and pics/msite_prefer_rookies.png are recently added placeholders. Could those be replaced with something that follows the widelands style?

The placeholder pictures have been downloaded from openclipart.org, and the site claimed that those would be public domain. Therefore, if the information on that web page was accurate, the placeholders should license-wise be compatible with widelands.

Hans Joachim Desserud (hjd) wrote :

I agree these icons doesn't really match the overall style and could be replaced with something more fitting.

I'm not a copyright laywer and I only learned about this recently, but it turns out different countries deal with public domain differently, and in some it is rather hard/impossible to put a piece of work in the public domain [1]. So we probably want to sort that out regardless.

[1] http://en.wikipedia.org/wiki/Public_domain#Dedicating_works_to_the_public_domain

Changed in widelands:
status: New → Confirmed
tags: added: graphic
Changed in widelands-media:
status: New → Confirmed
cghislai (charlyghislain) wrote :

Should this be marked as fixed or linked to branch lp:~widelands-dev/widelands/soldierselect_radiobutton

SirVer (sirver) on 2013-07-27
Changed in widelands-media:
status: Confirmed → Fix Committed
Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
Changed in widelands-media:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers