Fail to build in Ubuntu 12.04 LTS

Bug #1197429 reported by Jens Beyer on 2013-07-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
High
Unassigned

Bug Description

Transferred from the forum thread at https://wl.widelands.org/forum/topic/1216/

Fail to build on Ubuntu 12.04 LTS.

Setting to confirmed as I can reproduce it with a clean install of Ubuntu 12.04 LTS.

Related branches

Changed in widelands:
milestone: none → build18-rc1
importance: Undecided → Critical
Nasenbaer (nasenbaer) wrote :

Thank you for the fix Jens :)!

Just as note: I do not see a compilation problem on a specific old linux distribution as a critical bug for release of Build 18 - first of all because it would not be a problem for the ubuntu maintainers to provide an updated package of boost and second of all, because (like with the boost packages) they won't compile Widelands Build18 to their old (although its LTS) version.

But that's just a side note and surely a matter of taste ;)

So thank you again for the bug fix :)

Jens Beyer (qcumber-some) wrote :

Merged the bugfix branch. You are right with the Importance, I am going to correct that too. ;-)

Changed in widelands:
importance: Critical → High
status: Confirmed → Fix Committed
Hans Joachim Desserud (hjd) wrote :

Thanks for your fix, Jens. Fwiw, I just tried it on Ubuntu 10.04 and it builds/runs fine again there too. Looks like this issue was a lot easier than what I feared when I saw the forum post.

Changed in widelands:
assignee: Jens Beyer (Qcumber-some) (qcumber-some) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers