Ports build into water

Bug #1195639 reported by P. van Tillo on 2013-06-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Low
Unassigned

Bug Description

There are Ports that are being build into the water.

Widekands Ubuntu Build 6592. See savegame.

P. van Tillo (pvtillo) wrote :
Nasenbaer (nasenbaer) wrote :

obviously there was a port space placed on that coordinate in the editor before it was remodelled to be water.
Seems logical to check in the game whether a place is indeed valid or not. ;)

Changed in widelands:
status: New → Incomplete
status: Incomplete → Confirmed
assignee: nobody → Nasenbaer (nasenbaer)
Nasenbaer (nasenbaer) on 2013-06-30
Changed in widelands:
milestone: none → build18-rc1
tags: added: seafaring
Nasenbaer (nasenbaer) on 2013-06-30
Changed in widelands:
importance: Undecided → Low
Nasenbaer (nasenbaer) on 2013-07-13
Changed in widelands:
status: Confirmed → In Progress
P. van Tillo (pvtillo) wrote :

Hi,

I unzipped the map after converting to wmf (it was an Settlers 2 map).
Then I deleted all port_spaces. After that, I made new port_spaces into the editor. The problem was solved.
So this is happening if you make use of old settlers maps. (You don't know what port_spaces are already marked).

SirVer (sirver) wrote :

How did you do the conversion? I think there should not be any map spaces be defined on settlers 2 maps by default.

Nasenbaer (nasenbaer) wrote :

SirVer: they are defined. I improved the s2map.cc code during the seafaring code improvement. However it seems I have to reimprove it again :).

Fix for the bug is committed in rev. 6609 - I copy the commit message below, so I do not have to rewrite the fix explanation ;):

"Add function to determine the maximum theoretical available NodeCap of a field (without any map object on the field and neighbours) and use that function during seafaring expeditions to check whether a port space in the list of port spaces is valid - further readd a functionality to the map saver to remove all port build spaces from the port space list which will never be usable (this might break scenarios like the atlantean campaign, so we have to take care about port spaces in special scenarios manually, however this seems to be a much more smaller problem) - Fix the atlantean campaign map 1 according tothis change. This commit will unfortunally (as with the last two releases) break the savegames from atl01.wmf."

Changed in widelands:
status: In Progress → Fix Committed
P. van Tillo (pvtillo) wrote :

The conversion is quite simple. You load the settlers .swd map into the editor and save the map as .wmf map

Then rename .wmf to .zip and extract. You see now the portspaces. After deleting all port-spaces, compress the files back to .zip and rename them back to .wmf.

Nasenbaer (nasenbaer) wrote :

I further improved the S2 map loader. Now at least most of the port buildspaces should be converted to Widelands correctly. Widelands will send a message to all players at game start, if it fails to place one of the defined port buildspaces.

Nasenbaer (nasenbaer) on 2013-07-31
Changed in widelands:
assignee: Nasenbaer (nasenbaer) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments