Ship loads ware but does not transport it

Bug #1191889 reported by wl-zocker on 2013-06-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

Watch the attached replay (r6581). Notice the ship in the middle of the sea that is driving to the port. It picks up a plank from the dock, but never delivers them. The ship is going to be used for an expedition, where it loads three additional planks (needed to build a port). When constructing that port, all four planks are unloaded; the forth plank just disappears.
If you have a look at the "old" colony, you will notice the quarry missing a plank (*the* plank on the said ship). The plank is not delivered (because it is "on the way") until the ship is unloaded to form another colony. Then, a new plank is requested and delivered.
I do not know if it is associated with the new expedition feature, but I have never seen that behaviour before.

wl-zocker (wl-zocker) wrote :
wl-zocker (wl-zocker) wrote :
Nasenbaer (nasenbaer) on 2013-06-18
Changed in widelands:
milestone: none → build18-rc1
assignee: nobody → Nasenbaer (nasenbaer)
Nasenbaer (nasenbaer) wrote :

This bug is partly fixed now - partly because the ware does not get loaded on the ship anymore if the ship is about to start an expedition.

However the real bug I saw in the replays is, that the ship loads the planks and than just waits in front of the port - at that point the expedition is not yet ready, therefore there is no influence by the expedition.

Seems as if there was a request for the planks by the second port, but the request was gone, once the ship arrived to take the planks - but that's just brain storming, I haven't checked it in the code

Changed in widelands:
status: New → Confirmed
importance: Undecided → Medium
Nasenbaer (nasenbaer) wrote :

The second part of the bug is fixed as of revision 6589.

However the real underlying problem seems to be that at some point the pointer to the next transportation step gets invalid. This is exactly bug #985100 - therefore I close this bug as "fix committed".

Changed in widelands:
status: Confirmed → Fix Committed
Nasenbaer (nasenbaer) on 2013-07-31
Changed in widelands:
assignee: Nasenbaer (nasenbaer) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers