Port window not updated ("Cancel the expedition" starts a new one)

Bug #1191556 reported by wl-zocker on 2013-06-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

After having started an expedition and the wares are being delivered, cancelling the expedition will cancel it (as expected).
But if you keep the port window open and wait until the ship has arrived (the wares from the port will disappear), the button still reads "Cancel the expedition". However, when you click on it, another expedition will start. (Tested in r6581. Take care of bug 1191554 when trying to reproduce this one.)
Would it be able to update the window of the port when the expedition has started?

Related branches

Nasenbaer (nasenbaer) wrote :

agreed in all points :)

summary: - "Cancel the expedition" starts a new one
+ Port window not updated ("Cancel the expedition" starts a new one)
Changed in widelands:
status: New → Confirmed
tags: added: ui
Changed in widelands:
importance: Undecided → Medium
Nasenbaer (nasenbaer) on 2013-06-18
Changed in widelands:
assignee: nobody → Nasenbaer (nasenbaer)
milestone: none → build18-rc1
Nasenbaer (nasenbaer) wrote :

Fixed in bzr. 6585

Changed in widelands:
status: Confirmed → Fix Committed
Nasenbaer (nasenbaer) on 2013-07-31
Changed in widelands:
assignee: Nasenbaer (nasenbaer) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
wl-zocker (wl-zocker) wrote :

This happens again in r7199. The button still says "Cancel", but a new expedition is started.
Even when there is no expedition, there is an empty expedition tab.
Could maybe be fixed at the same time: When the status of an expedition changes (started/cancelled/ship gets loaded), the first tab of the port (showing the wares) becomes active. It would be nice if the currently active tab stayed active.

Changed in widelands:
status: Fix Released → New
SirVer (sirver) wrote :

This can be implemented using the notifications framework and should work non-obstructively.

tags: added: regression
Hans Joachim Desserud (hjd) wrote :

Updated milestone so we don't forget about this for build19.

Changed in widelands:
milestone: build18-rc1 → build19-rc1
Hans Joachim Desserud (hjd) wrote :

Confirmed in r7438.

Looks like when you cancel an expedition in the port window, the button never goes back to start expedition, so it is effectively possible to toggle it on and off by clicking "cancel" multiple times.

Changed in widelands:
status: New → Confirmed
GunChleoc (gunchleoc) wrote :
GunChleoc (gunchleoc) on 2016-03-03
Changed in widelands:
status: Confirmed → In Progress
assignee: nobody → GunChleoc (gunchleoc)
GunChleoc (gunchleoc) on 2016-03-12
Changed in widelands:
status: In Progress → Fix Committed
assignee: GunChleoc (gunchleoc) → nobody
Klaus Halfmann (klaus-halfmann) wrote :

Looks like this was fixed in the Branch created by Gun.

GunChleoc (gunchleoc) on 2016-10-25
Changed in widelands:
status: Fix Committed → Fix Released
GunChleoc (gunchleoc) wrote :

Fixed in build19-rc1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers