Game crashes when ship with open window is loaded for expedition (Was: Game crashes when second expedition is started)

Bug #1191554 reported by wl-zocker on 2013-06-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Undecided
Unassigned

Bug Description

When a ship arrives to load the wares needed for an expedition and its window (where you can see the loaded wares) is open, the game crashes (Widelands closes) without any error message. This also happens in replays.
Tested in r6581

last few lines of stdout.txt before the crash:
Done reloading the game from replay
Replay writer has started
[sync] Reset
Autosave: initialized

(ignore comments until #4; they were based on wrong assumptions)

Nasenbaer (nasenbaer) wrote :

I just tried it - same port two expeditions - no saving and loading inbetween, but I could not reproduce the bug. :-/
Did you do anything special aside of the things you already mentioned?

Changed in widelands:
status: New → Incomplete
assignee: nobody → Nasenbaer (nasenbaer)
wl-zocker (wl-zocker) wrote :

It seems that the bug is not that easy to reproduce (it happened 2 of 2 times before I reported the bug, but now only one out of 5 tries).
I therefore attach one of the replays. The expedition preparation has already started, just wait some minutes at high speed (20x). I hope that the game will crash ;) I wonder whether that is because the ship that shall transport the wares of the expedition already has a plank on board.

wl-zocker (wl-zocker) wrote :
wl-zocker (wl-zocker) wrote :

A thought just came to my mind: I think the ship that was going to be used for the expedition was selected (its windows with the wares in it was open) when it was being loaded. Could someone verify if that is the reason (I am tired of testing and loading now)?

wl-zocker (wl-zocker) on 2013-06-17
description: updated
summary: - Game crashes when second expedition is started
+ Game crashes when ship with open window is loaded for expedition (Was:
+ Game crashes when second expedition is started)
Nasenbaer (nasenbaer) on 2013-06-18
Changed in widelands:
status: Incomplete → Confirmed
milestone: none → build18-rc1
Astuur (wolfsteinmetz) wrote :

I guess I have stumbled across the same bug . Unfortunately I cannot remember whether I had really the window open for the ship that was to go to an expedition. It may have been some other ship.
Same thing, I prepared an expedition (from a port on an island already colonized by ship) and shortly after the game crashed without any error message.
Anyway, I have a stout.txt (stderr is empty), a replay, and the last automatic savegame
When an arena is built east of the port on the agricultural island, you are getting close to the end ot the replay.

Nasenbaer (nasenbaer) wrote :

This bug should be fixed in bzr rev. 6585 - the window gets now reloaded before Widelands would refresh it and therefore segfault and crash.

Please reopen in case it reappears.

Changed in widelands:
status: Confirmed → Fix Committed
Nasenbaer (nasenbaer) on 2013-07-31
Changed in widelands:
assignee: Nasenbaer (nasenbaer) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers