WL crashes down while ship makes expedition

Bug #1189615 reported by Kristin on 2013-06-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Undecided
Unassigned

Bug Description

When continuing the current expedition (63,115) in the attached savegame by clicking "clockwise", WL crashes down after the ship has passed some stones in the water before the neighbor island.

SirVer (sirver) wrote :

Note: the safegame is from the seafaring branch.

Changed in widelands:
assignee: nobody → Nasenbaer (nasenbaer)
Nasenbaer (nasenbaer) wrote :

Please upload the savegame :)

tags: added: seafaring
Kristin (ha-kripo) wrote :

oh, ok... sorry

Nasenbaer (nasenbaer) wrote :

I see :) .
This bug only appeared because I changed the way how Widelands calculates (for expedition ships) whether one direction is swimable or not (I think in bzr rev. 6289 - your savegame is from 6286 - so your savegame includes the old style, which is not compatible to the new one)

However all savegames from trunk / Build17 will work without problem, so I set this fix committed :)

Changed in widelands:
status: New → Fix Committed
Nasenbaer (nasenbaer) on 2013-06-15
Changed in widelands:
milestone: none → build18-rc1
Nasenbaer (nasenbaer) on 2013-07-31
Changed in widelands:
assignee: Nasenbaer (nasenbaer) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers