Evict Worker code possibly incomplete

Bug #1183479 reported by Nasenbaer on 2013-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Undecided
Unassigned

Bug Description

During the coding of the different player commands in the seafaring branch, I noticed, that there is no entry for "QUEUE_CMD_EVICTWORKER" (defined in queue_cmd_ids.h) in the command factory for save game loading (queue_cmd_factory.cc)

I am not sure whether this is an actual bug or handled elsewhere, but as I stumbled over it, I thought "better report it, before that's a real bug!" ;)

Gabriel Margiani (gamag) wrote :

This seems to be a bug, and the reason for bug1162936

Changed in widelands:
status: New → Confirmed
Nasenbaer (nasenbaer) wrote :

As I wrote in bug 1162936 I unfortunally have to disagree - the missing entry in the code would lead to a wexception("Unknown Queue_Cmd_Id in file: %u", id) and not to the message reported in bug 1162936.

Nasenbaer (nasenbaer) on 2013-05-25
Changed in widelands:
assignee: nobody → Nasenbaer (nasenbaer)
Nasenbaer (nasenbaer) wrote :

I committed a patch in bzr rev. 6570

Changed in widelands:
status: Confirmed → Fix Committed
milestone: none → build18-rc1
Nasenbaer (nasenbaer) on 2013-07-31
Changed in widelands:
assignee: Nasenbaer (nasenbaer) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers