Setting the origin of a map disrupts it

Bug #1174066 reported by wl-zocker on 2013-04-28
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

Load any map in the editor. To see better what happens, the map should not be too complicated (e.g. http://wl.widelands.org/maps/settlers-of-wlatan/). Now go to the map options and set a new origin. You will notice some strange lines in the map.

It seems as if the terrain on the axis (x and y resp. horizontal and vertical) of the new origin is copied to the old origin. If you set the new origin e.g. into the sea, you get a cross of water at the old origin (in the screenshot, for some reason only a vertical line has been produced. If you click back to the desert, you will see the cross of land in the water).

wl-zocker (wl-zocker) wrote :
Nicolai Hähnle (nha) wrote :

Thank you for the report, but I am unable to reproduce this in trunk bzr6568.

I have loaded exactly the map you mentioned in the editor, and I have used the "Set origin" button many times in different locations, but no such cross as you show it has been produced. Perhaps you can find a more precise list of steps to reproduce this?

wl-zocker (wl-zocker) wrote :

I'm on Win7 and I use Tino's builds, therefore the version I tested it with is r6567. It is equal whether OpenGL is enabled or not.

I just start Widelands, start the editor, and load any map. Then I set a new origin. The strange lines will appear.
When I load another map or just quit the editor, Widelands crashes. I cannot remember this happened when I reported the original bug.

Nasenbaer (nasenbaer) wrote :

I just faced this problem over here as well (linux x86 32-bit) it is 100% reproducible. Maybe I try to debug this in the next time, if nobody wants to do it before.

Changed in widelands:
milestone: none → build18-rc1
Hans Joachim Desserud (hjd) wrote :

Marking confirmed based on Nasenbaer's comment above.

Changed in widelands:
status: New → Confirmed
Nasenbaer (nasenbaer) on 2013-06-19
Changed in widelands:
importance: Undecided → Medium
Nasenbaer (nasenbaer) on 2013-07-30
Changed in widelands:
assignee: nobody → Nasenbaer (nasenbaer)
Nasenbaer (nasenbaer) wrote :

Fix committed in revision 6684 of trunk

Changed in widelands:
status: Confirmed → Fix Committed
assignee: Nasenbaer (nasenbaer) → nobody
Nasenbaer (nasenbaer) wrote :

By the way the textures change slightly if y is odd, this is due to the graphics recalculation. To avoid this behaviour, the only possible solution would have been to disallow changes with an odd y coordinate...

SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers