After eviction of a worker, a worker of the same level is requested instead of the original worker type

Bug #1162936 reported by Joe on 2013-04-01
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
widelands
High
Unassigned

Bug Description

I saved a game with bzr6549, but bzr6549 does not load the game. It shows the error message "Gebäudedaten: Gebäude 3278: production site(Axtmanufaktur): site has request for master blacksmith, for which there is no working position".
Don't know if this helps: I have used the new option to send away workers on my "Axtmanufaktur".

(attached is the savegame)

Joe (joe-kleine-schweiz) wrote :
SirVer (sirver) wrote :

Indeed - there seems to be a bug lurking in there somewhere.

Changed in widelands:
status: New → Confirmed
importance: Undecided → High
milestone: none → build18-rc1
_aD (ad-simplypeachy) wrote :

buildingdata: building 2957: productionsite (Marble Mine): site has request for master-miner, for which there is no working position.

Before I saved this I had evicted a master miner from a (normal) marble mine. I had no other master miners. This miner was sent to a deep coal mine which then began operation. The marble mine would have been left with no available workers.

_aD (ad-simplypeachy) wrote :

I forgot to mention that I am also using build 6549.

summary: - Cannot load savegame with bzr6549
+ Cannot load savegame if there are no workers for production site
tags: added: eviction productionsite savegame worker
Nasenbaer (nasenbaer) on 2013-05-17
summary: - Cannot load savegame if there are no workers for production site
+ Evict worker function breaks savegames

Peter found the reason for this in bug 1183479.

Nasenbaer (nasenbaer) wrote :

I disagree with #5 - bug 1183479 would lead to a wexception("Unknown Queue_Cmd_Id in file: %u", id) and not to the message reported above.

However this bug here is most likely related to bug 1181278 - as in both bugs the reason seems to be the following:
* A higher educated worker was kicked out of a slot for a smaller educated worker
* During this, a request for the higher educated worker is generated and not for the normal worker of that working position.

I haven't checked it in the code, but I am pretty sure, that this must be the case, as it would explain both, this bug and bug 1181278

summary: - Evict worker function breaks savegames
+ After eviction of a worker, a worker of the same level is requested
+ instead of the original worker type
Nasenbaer (nasenbaer) on 2013-05-25
Changed in widelands:
assignee: nobody → Nasenbaer (nasenbaer)
Nasenbaer (nasenbaer) wrote :

The bug should be fixed in rev. 6570 of trunk - that to say, the bug should not reappear in new saved games, but it does not fix the broken saved games, sorry.

Changed in widelands:
status: Confirmed → Fix Committed
MP (pagel-d) wrote :

related: in 6667 I tried to kick out a chief miner from a mine level 2, as I had a master present (and needed a chief in either a l3 or l2 mine elsewhere). I wanted the chief to be replaced with a fresh recruit, but the chief refused to leave.

So, I was trying to remove the miner with LESS experience from a mine. Previously when I had kicked out a master miner from a different mine and there was no where else for him to go, he went down to his flag, then back to the hut (I can't remember if he could be replaced or not with a lower level miner).

haven't tested in 6680 yet.

Nasenbaer (nasenbaer) on 2013-07-31
Changed in widelands:
assignee: Nasenbaer (nasenbaer) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers