Builder gets "lost" after dismantling site

Bug #1144465 reported by Kiscsirke on 2013-03-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

Tested with rev 6526. After a builder finished dismantling a building, he is "lost", like a worker whose home was just destroyed, he wonders around a bit until he finds a flag, and only goes home after. He takes the last building material to the flag, goes back to the dismantle site and as soon as he gets there it disappears and he is "lost".

Expected behaviour: When taking the last building material back to the flag, he should just go home to the warehouse.

Related branches

Hans Joachim Desserud (hjd) wrote :

Great catch. I was under the impression that workers had behaved as expected earlier, and they do not become lost in build 17. Not sure how recently this regressed or what triggered it though...

Changed in widelands:
importance: Undecided → Medium
milestone: none → build18-rc1
status: New → Confirmed
tags: added: regression
Nicolai Hähnle (nha) on 2013-03-04
Changed in widelands:
assignee: nobody → Nicolai Hähnle (nha)
cghislai (charlyghislain) wrote :

Also see 1162918

cghislai (charlyghislain) wrote :

nicolai I hope you don't mind, but I committed a quick fix in the linked branch.
Your review for merging this will be very welcome as you seems to know better that part of the code.

Changed in widelands:
status: Confirmed → In Progress
SirVer (sirver) wrote :

I unassigned nicolai - he seems to be too busy with other stuff right now.

Changed in widelands:
assignee: Nicolai Hähnle (nha) → nobody
Changed in widelands:
status: In Progress → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers