change yellow color in white(?) - building menu % is unreadable

Bug #1132476 reported by LAZA on 2013-02-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Low
cghislai

Bug Description

Widelands 6515:

Opening up the build menu from the building gives us a yellow bar and the per cent numbers also in yellow, making them complete unreadable.

Tags: ui Edit Tag help

Related branches

LAZA (laza74) on 2013-02-24
description: updated
Hans Joachim Desserud (hjd) wrote :

I'm not sure exactly where in the game you mean. Could you please attach a screenshot?

Changed in widelands:
status: New → Incomplete
LAZA (laza74) wrote :

At the moment not... sorry!

I describe it (can i do this in Swabian German :) ?

- build a building
- right-click on it --> menu opens up
- within this menu is an progress bar
-- the color of the bar itself is yellow
-- the color of the numbers in percent is dependent of the progress
--- at the middle of the progress = the yellow bar and yellow numbers

I hope this was clear enough to reproduce...

Hans Joachim Desserud (hjd) wrote :

Ok, your description is confusing me a bit, but let's see if I got this right:
1. Build some building
2. A) Right-clicking buildings does nothing for me here... ? However:
2. B) Clicking on a construction site for a building being built opens a window with a progress bar.

As the building is built, this progress bar fills up, and around 50% the text does indeed blend into the background because they use the same color, and otherwise matching your description.

(Btw: we don't seem to have a progress bar in buildings, didn't we use to have that at some point? (Or am I just thinking of another game?)

Hans Joachim Desserud (hjd) wrote :

Also affects the progress bar shown in building statistics, presumably using the same progress bar controller.

Changed in widelands:
importance: Undecided → Low
status: Incomplete → Confirmed
tags: added: ui
LAZA (laza74) wrote :

Nice pic, you got another bug but with the same problem!

I will (to clear up the case) send/post some screen shoots - which is shurely the best way. :-)

Changed in widelands:
assignee: nobody → cghislai (charlyghislain)
status: Confirmed → In Progress
Hans Joachim Desserud (hjd) wrote :

The white on green might not be the easiest to read (possibly consider future improvement), but the text and background have different colors in all situations now.

Changed in widelands:
milestone: none → build18-rc1
status: In Progress → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments