Evicted workers will become stuck if the are away from home and the building is not conencted to the road network

Bug #1132466 reported by Hans Joachim Desserud on 2013-02-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Nicolai Hähnle

Bug Description

Steps to reproduce:

1. Build a building where the worker ventures outside to perform his/her task, for instance a quarry.
2. When the building becomes occupied with a worker, destroy any roads leading to the building.
3. Open the building window and select the worker.
4. When the worker leaves the building to perform his/her task, click on the button to evict the worker.

Expected result:
The worker will stop, turn around and head back to HQ/nearest warehouse.

Actual result:
The worker becomes stuck, looping the walk animation over and over. Only when the building is yet again connected to a road network do they become unstuck.

Oddly enough the workers seem to have no problem finding their way back home if they are in their houses when evicted, even if no roads are available.

I was really happy when bug 714036 was resolved, and I gather a lot of players have been waiting for this feature. Therefore I think it is pretty important we manage to iron out this and any other bugs it might have, because it is going to affect a lot of people once build18 is out.

Widelands bzr r6515

Related branches

Nicolai Hähnle (nha) on 2013-02-24
Changed in widelands:
status: New → Confirmed
assignee: nobody → Nicolai Hähnle (nha)
Nicolai Hähnle (nha) wrote :

Fix committed to trunk in bzr6522.

Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers