segmentation fault when running with --dedicated

Bug #1128114 reported by Balint Vekerdy on 2013-02-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

System:
Headless CentOS 5 (64bit) virtual server

Widelands:
version: build17
built from source (through bzr)

$ gdb widelands
(gdb) run --dedicated=/home/uname/widelands/maps/Atoll.wmf
Starting program: /home/uname/widelands/widelands --dedicated=/home/uname/widelands/maps/Atoll.wmf
warning: Selected architecture i386:x86-64 is not compatible with reported target architecture i386
warning: Architecture rejected target-supplied description
Can't read symbols from system-supplied DSO at 0x2aaaaaacb000: File truncated
[Thread debugging using libthread_db enabled]
Set home directory: /home/uname/.widelands
No version file found
There's no configuration file, using default values.
Adding directory:./.
Version file found with id "bzr6513[widelands]" (real "bzr6513[widelands]" )
No version file found
Adding directory:/usr/share/games/widelands
Adding directory:.
Version file found with id "bzr6513[widelands]" (real "bzr6513[widelands]" )
No version file found
Adding directory: /home/uname/widelands
Version file found with id "bzr6513[widelands]" (real "bzr6513[widelands]" )
No version file found
Widelands executable directory: /home/uname/widelands/
localedir: /home/uname/widelands/locale
selected language: (system language)
using locale en_GB.utf8

Program received signal SIGSEGV, Segmentation fault.
0x00000000005ad906 in UI::create_fonthandler(Graphic*, FileSystem*) ()
Missing separate debuginfos, use: debuginfo-install SDL-1.2.14-3.el6.x86_64 SDL_gfx-2.0.22-1.el6.x86_64 SDL_image-1.2.10-1.el6.x86_64 SDL_mixer-1.2.11-3.el6.x86_64 SDL_net-1.2.7-7.el6.x86_64 SDL_ttf-2.0.9-6.el6.x86_64 boost-signals-1.41.0-11.el6_1.2.x86_64 freetype-2.3.11-14.el6_3.1.x86_64 glew-1.5.5-1.el6.x86_64 glibc-2.12-1.80.el6_3.7.x86_64 libX11-1.3-2.el6.x86_64 libXau-1.0.5-1.el6.x86_64 libXdamage-1.1.2-1.el6.x86_64 libXext-1.1-3.el6.x86_64 libXfixes-4.0.4-1.el6.x86_64 libXxf86vm-1.1.0-1.el6.x86_64 libdrm-2.4.25-2.el6.x86_64 libgcc-4.4.6-4.el6.x86_64 libjpeg-6b-46.el6.x86_64 libpng-1.2.49-1.el6_2.x86_64 libstdc++-4.4.6-4.el6.x86_64 libtiff-3.9.4-9.el6_3.x86_64 libxcb-1.5-1.el6.x86_64 lua-5.1.4-4.1.el6.x86_64 mesa-libGL-7.11-5.el6.x86_64 zlib-1.2.3-27.el6.x86_64

(gdb) backtrace
#0 0x00000000005ad906 in UI::create_fonthandler(Graphic*, FileSystem*) ()
#1 0x0000000000527e09 in WLApplication::WLApplication(int, char const* const*)
    ()
#2 0x0000000000528008 in WLApplication::get(int, char const**) ()
#3 0x0000000000521427 in main ()

Related branches

Hans Joachim Desserud (hjd) wrote :

Hi Balint and welcome to Launchpad!

I was able to reproduce this issue on Ubuntu 12.10 with latest development version, so it doesn't seem to be Centos-specific at least.

Changed in widelands:
importance: Undecided → Medium
status: New → Confirmed
tags: added: crash dedicated
Gordon Folderol (blasedef) wrote :

Same seen on CentOS 6:

./widelands --dedicated=maps/Atoll.wmf
Set home directory: /home/tw/.widelands
No version file found
There's no configuration file, using default values.
Adding directory:./.
Version file found with id "bzr6513[widelands]" (real "bzr6513[widelands]" )
No version file found
Adding directory:/usr/share/games/widelands
Adding directory:.
Version file found with id "bzr6513[widelands]" (real "bzr6513[widelands]" )
No version file found
Widelands executable directory: /home/twig/widelands/widelands/
localedir: /home/tw/widelands/widelands/locale
selected language: (system language)
using locale en_US

Gordon Folderol (blasedef) wrote :

err - it chopped off the last sentence:

Segmentation fault

SirVer (sirver) wrote :

I believe this is the recent changes done in the graphics code. I didn't care for dedicated mode very much, so it is very likely that I missed to add a few if (g_gr) in the right places.

This should be easy to fix and a low hanging fruit for new developers.

Changed in widelands:
milestone: none → build18-rc1
tags: added: lowhangingfruit
Jens Beyer (qcumber-some) wrote :

@SirVer: The original bug says Build 17 - are you sure this can be caused by your graphic changes lately?

Jens Beyer (qcumber-some) wrote :

The problem in trunk is indeed a missing if (g_gr) - see merge request.

Build17 does not contain the source line in question, and for me build17 from bzr works with --dedicated. Additionally to that, the build description says bzr6513[widelands] as version id, which strongly suggests a trunk build (build17 is at rev. 6348, and widelands is the common branch nick when doing 'bzr branch lp:widelands'. So I guess the bug description is wrong. Build17 is not affected.

Nasenbaer (nasenbaer) wrote :

Thanks Jens for your fix. Unfortunally it did not solve the whole problem for me, however I found the second bugger quite fast, so the dedicated server functionality should work again.
Can someone please check whether the dedicated server works again as it should? (no IPv4 over here to test it myself)

Changed in widelands:
assignee: nobody → Nasenbaer (nasenbaer)
Nasenbaer (nasenbaer) on 2013-03-08
Changed in widelands:
status: Confirmed → In Progress
Balint Vekerdy (vekerdyb) wrote :

I can confirm, that now it is working on my system, after running the update script. (Using IPv4.)

PS: Sorry for the faulty bug report

Nasenbaer (nasenbaer) wrote :

Thanks for the feedback Balint Vekerdy. Closing the bug as fix committed :).
Btw.: it is much better to report a bug with a fault in the description, than not reporting it - so thank you for your report :).

Changed in widelands:
status: In Progress → Fix Committed
Nasenbaer (nasenbaer) on 2013-07-31
Changed in widelands:
assignee: Nasenbaer (nasenbaer) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments