Assertion error upon starting WL (regression after latest opengl changes)

Bug #1121396 reported by Hans Joachim Desserud on 2013-02-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Critical
Unassigned

Bug Description

Attempting to start latest development version of WL currently triggers an assertion error:
src/graphic/image_transformations.cc:320: {anonymous}::ResizedImage::ResizedImage(const string&, const Image&, SurfaceCache*, uint16_t, uint16_t): Assertion `w != original.width() || h != original.height()' failed.

See attached log for details. It was working fine before I compiled 6501 (the big changes with opengl+memory footprint), so that commit caused a regression. Which is a shame, because it sounds really nice based on the commit message. :)

Widelands bzr r6502 on Ubuntu 12.10.

Hans Joachim Desserud (hjd) wrote :
SirVer (sirver) wrote :

Should be fixed in r6506. Expect more trouble, this were two huge refactorings/improvement patches.

Changed in widelands:
status: New → Fix Committed
SirVer (sirver) wrote :

ups... fixed in r6507 :/.

Hans Joachim Desserud (hjd) wrote :

Verified fixed in 6507. Thanks for the quick response.

>Expect more trouble, this were two huge refactorings/improvement patches.

Yes, I saw that. I'll keep an eye out for more regressions. ;)

SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments