Open windows cause game to stall after several hours

Bug #1096632 reported by _aD on 2013-01-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
High
Unassigned

Bug Description

Symptoms as per 1074655 - after several hours of gameplay with stock, message and colosseum windows open, game stalls very badly until colosseum window closed. Once bug occurs it happens seconds after opening any production site window. Closing the stock/message windows did not return game to normal - only closing production site window returned the game to normal speed.

I often play with these three windows open for a long time and have only recently seen this bug. It has happened twice now.

Other detail at https://bugs.launchpad.net/widelands/+bug/1074655/comments/9

SirVer (sirver) wrote :

Are you positive that it is a regression? Could you attach a busy safegame - spares me some cycles to reproduce one :).

_aD (ad-simplypeachy) wrote :

I am certain - I've never come across this problem before, and have played long games with the same windows open before.

I can supply a save but when the game is re-loaded the bug goes away again for several hours.

_aD (ad-simplypeachy) wrote :

I meant to also add that I thought it may be a regression as it was related to bug 1074655 , which was also tagged as regression.

SirVer (sirver) wrote :

regressions must be handled for b18 of course.

Changed in widelands:
status: New → Confirmed
milestone: none → build18-rc1
importance: Undecided → High
_aD (ad-simplypeachy) wrote :

Doesn't just affect production site windows.

summary: - Production site windows cause game to stall
+ Open windows cause game to stall after several hours
_aD (ad-simplypeachy) wrote :

Confirming regression - I played build 17 yesterday for many hours and had no problem. In case it is relevant, sometimes UI elements in windows that trigger the stall are often left black and tooltips sometimes show their background colour but no text.

I have also found that other windows cause the stall as well - the menu and save game window also triggered it. I'll try to pin down if it has anything to do with the stock window being opened for any length of time.

_aD (ad-simplypeachy) wrote :

Having checked my replays and the versions of Widelands I've played, I think this bug was introduced after revision 6467.

_aD (ad-simplypeachy) wrote :

Bug also triggers on replays, and can be caused by having the minimap window open for long periods. Build 17 does not suffer the bug after the steps to reproduce.

To reproduce:
Open attached replay in trunk revision 6467 or later (earliest I have available).
Open the minimap.
Increase game speed to 10x, or whatever speed you can use smoothly. On my system at 10x it takes around 20 minutes to trigger the bug.

_aD (ad-simplypeachy) wrote :

With trunk version 6567 I played a replay for 30 minutes without suffering this symptom and haven't experienced it while playing for a long time. I believe this bug is now fixed.

Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers