Crash when increasing speed in a internet game as observer (only happens on dedicated servers)

Bug #1096362 reported by Andreas Breitschopp on 2013-01-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

The game crashes when you increase the speed in a internet game as observer.

You can reproduce the bug this way:
- start a internet game with AI players only (no human player) => you are the observer.
- try to increase game speed.
=> This will result in a crash like the screenshot attached.

Hans Joachim Desserud (hjd) wrote :

Based on your screenshot this is obviously an issue, but I am not able to reproduce it here. What I did:
1. Create a new multiplayer game (tried both LAN and Internet game).
2. Host it myself
3. Pick a random map, assign AIs to all positions and start a new game.
4. Press page up to increase speed.

I wonder, did this crash happen on your dedicated server (thanks for setting that up, btw :) )? If so, could you check whether it also happens when starting a normal game, like hosting a local LAN game? Maybe dedicated servers handle this differently for some reason.

tags: added: crash multiplayer
Changed in widelands:
importance: Undecided → Medium
Andreas Breitschopp (ab-tools) wrote :

Yes, indeed, I tested that with my didicated server and I cannot reproduce it in a local network game.

Hans Joachim Desserud (hjd) wrote :

Yes, I tried with your dedicated server right now and that did indeed crash. From what I can see, the use gets the error message:
"Client sent malformed commands: vector::_M_range_check"
Then only after closing this dialog and waiting a while (probably disconnecting the user) the game crashes. See attached backtrace.

Changed in widelands:
status: New → Confirmed
milestone: none → build18-rc1
summary: - Crash when increasing speed in a internet game as observer
+ Crash when increasing speed in a internet game as observer (only happens
+ on dedicated servers)
Andreas Breitschopp (ab-tools) wrote :

And the strange thing is it only happens if all players are AI players.

Therefore that's also not the most important bug, but anyway, it is a bug. ;-)

SirVer (sirver) wrote :

dedicated server => nasenbaer :)

Changed in widelands:
assignee: nobody → Nasenbaer (nasenbaer)
Nasenbaer (nasenbaer) wrote :

Jepp that was a stupid little bug :-D ... fixed in rev. 6481

Changed in widelands:
status: Confirmed → Fix Committed
Andreas Breitschopp (ab-tools) wrote :

Great, that was a quick fix, thanks Peter!

Nasenbaer (nasenbaer) on 2013-07-31
Changed in widelands:
assignee: Nasenbaer (nasenbaer) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers