Fisher runs out of fish even with double breeders

Bug #1094711 reported by Mattias Wadenstein on 2012-12-30
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
widelands
Undecided
Unassigned

Bug Description

On long games, the Atlantean fisher runs out of fish, even when I have placed two fish breeders, one on each side, for each fisher.

It takes about 8-12 hours for them to run out, so it only shows in really long games. But it is annoying because then the protein sources starts slowly moving further and further away from the HQ, as well as possibly running out if I can't capture new coast (that hasn't been fished out already).

I should think that just alternating fishers and breeders along a stretch of coast should be sufficient for "infinite" fish supply. But with this strategy the fishers seem to run out even faster (4-8 hours, I think it was).

I've seen this multiple times on multiple maps, since my preferred gameplay is long single games building a big economy on a big map.

Related branches

tags: added: atlanteans
Jens Beyer (qcumber-some) wrote :

Fisher: 16s+3s+walk cycle
Fishbreeder: 24s+3s+walk cycle

So, alternating fishers with fishbreeders will slowly kill the fish. I guess that's by design and not really a problem.

But I've never seen, nor can I conclude it from the numbers, that two fish breeders very close to the fisher (and nobody else around) makes the fish disappear.

Mattias Wadenstein (maswan) wrote :

Ok, I will test around and see under what circumstances I can trigger the 2 breeder + 1 fisher run-out. Possibly with multiple of those groups partially overlapping or something.

Jens Beyer (qcumber-some) wrote :

We have another bug here (although I can not find it currently), which says that fishers can not fish when the shoreline is occupied by immovable objects like trees, streets, houses, flags, wheat... so maybe this happens if your fisher needs to run too far and one of the two fishbreeders does not even have this place in its working area.

If you find a way to reproduce this, a savegame attached to this bug would definitely be very helpful.

Mattias Wadenstein (maswan) wrote :

I'm trying, but the two fishers nearest my HQ in Four kingdoms that ran out of fish in a long game don't seem to be running out when I run the same locations for fisher&breeder in a more minimal game at high speed-up for much longer game time.

Attaching a big savegame, note the two stopped fishers near the HQ.

_aD (ad-simplypeachy) wrote :

I don't understand why Atlanteans have to suffer from the prospect of losing their food economy. Empire and Barbarians can always produce meat, so it seems illogical that fish breeders can fail under some conditions. Is there a reason for this behaviour?

Paul Pogonyshev (doublep) wrote :

Fish breeders should just be able to introduce more fish, not only breed existing (think of it as breeding larvae in large barrels at site, then releasing them to mature in a large water body). Empire has infinite meat with piggeries. Barbarians has infinite meat with gamekeeper which, I believe, can create game from scratch, not just breed. The same should go for Atlanteans.

There are more reasons why breaders should be able to add more fish. There is zero visual indication of if there is fish and how much. It is easy to accidentally deplete your resources.

Also, consider conquering a lake from other tribe or just reaching a shore of a pond where fish was already fished out by previous owners. For Atlanteans this new water is now pretty useless, whereas both Empire and Barbarians can always use more land to produce more meat.

Nicolai Hähnle (nha) wrote :

Another vote for fish breeders to act conceptually like the Barbarian's game keeper. Paul's arguments are very good.

Borim (borim) wrote :

I vote also for Paul's suggestion for an infinite fish supply.

Nasenbaer (nasenbaer) wrote :

I generally agree with Paul (#6), but would prefer to increase the needed time for a 0 -> 1 fish breeding action.

So to say: keep the fishbreeder as it is, and only IF it fails to breed fish somewhere, where there is at least 1 fish - automatically try to bread in a 0 fish region, which however takes more time (e.g. doubled...)

Mattias Wadenstein (maswan) wrote :

Either longer time, or x% chance of success much like empty mines. Would still make it a recoverable situation if you run out at Atlanteans, but still a good incentive to keep the ponds stocked.

cghislai (charlyghislain) wrote :

Currently the breeder program looks for a node that is breedable, that is, not full nor empty. But for the actual breeding, it will look for a neighboring node, and introduce a fish in there even if it is empty. I guess one of the two condition is not by design.

I will link a branch to this bug with a few fixes related to fishers/breeders, so that running out of fish will become less likely hopefully.

cghislai (charlyghislain) wrote :

I made a test at full speed with 2 fishers for 2 breeders.
After 9 hours (screenshot), all were still at 100% productivity, and the fields were refilled with fish at decent speed, at about ~17/20 capacity on average.
I built a road on the coast for another 10h, and the fish were still present. Some nodes were at no more than 3/20, sometimes dropping to 0. But as breeders may breed in an adjacent node, they were refilled again.
I think I can safely close this bug then :)

Changed in widelands:
status: New → Fix Committed
Changed in widelands:
milestone: none → build18-rc1
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers