Implement IPv6 solution for internet gaming

Bug #1092567 reported by Nasenbaer on 2012-12-20
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Fix Released
High
Unassigned

Bug Description

Since my move to a new flat, I got a new internet provider and guess what... I don't get an IPv4 Adress anymore, only IPv6.

Problem is, I am unable to host a Widelands game. Ports are forwarded, but it seems that forwarding will only work for ipv4 adresses.

So we should really implement a solution, as IPv6 will get more common year after year.

Related branches

SirVer (sirver) wrote :

Wow, that is awesome! I am glad that ipv6 is finally seeing some real use.

But for Widelands that will mean a lot of work methinks. Afaik, SDL_Net has no clue about ipv6 (maybe whoever tries to implement this in WL should start by providing this upstream) and even if it would, there is a lot of network code in Widelands that is OS specific and that must keep working.

Nasenbaer (nasenbaer) wrote :

It's time for SDL_net 1.3 and thus SDL 2.0 ;) -> http://www.soulsphere.org/hacks/ipv6/newapi.html

I guess the best would be, to wait until SDL 2.0 is released and port Widelands to it as well as SDL_net 1.3

SirVer (sirver) wrote :

Is there even work going on on SDL 2.0? I remember that we have already talked about it like 6 years ago - and afaik it is still not released. Maybe we can switch to a beta version, but I do not wish to get involved into the maintenance of SDL because it is too buggy.

Mark Scott (mxsscott) wrote :

SDL 2.0 is deceased. SDL 1.3 is next, according to this: http://sdl.beuc.net/sdl.wiki/FAQ_SDL_Version_2

There has been recent activity in the Mercurial repository (e.g. Sam committing my OSX fix for SDL_Image), but nothing looking like IPv6.

Nasenbaer (nasenbaer) wrote :

The situation is indeed unclear.

@Mark Scott (#4): The page you linked is from 2008 showing a text dating back to 2006. So I doubt it is really up to date

More up to date: http://www.phoronix.com/scan.php?page=news_item&px=MTE0MDU

I think it is interesting, that the main page of the official Wiki on libsdl.org shows on 2.0 content + a MigrationGuide from SDL1.2 to 2.0 : http://wiki.libsdl.org/moin.cgi/MigrationGuide

Including the information "The official extensions SDL_image, SDL_ttf, SDL_mixer and SDL_net have a version dedicated to SDL2.0 : SDL2_image, SDL2_ttf, SDL2_mixer and SDL2_net." as well as "SDL_gfx can also be compiled with 2.0 starting since 2.0.21 (May 2010)" --> So all SDL libraries we are currently using will be available or are already.

Btw.: the Roadmap can be found at: http://wiki.libsdl.org/moin.cgi/Roadmap

HOWEVER there is no ETA and thus I still vote for "keep things as they are for now" - maybe for one or even two further Widelands releases and moving to SDL2 + SDL2_* as soon as it gets released.

cghislai (charlyghislain) wrote :

SDL 2 is release candidate now

SirVer (sirver) wrote :

That is good news. I thought they gave up on version 2 by now.

However, SDL is a main dependency for us. We'll need to wait till this trickled to all the distributions and I want to see if it is mature enough to support us. So we are still talking a timeframe of months before switching really.

SirVer (sirver) wrote :

I think this won't happen for b18. As long as we are stuck on sdl 1 we won't have it and we will not switch before. Retargetting.

Changed in widelands:
milestone: build18-rc1 → build19-rc1
Teppo Mäenpää (kxq) wrote :

How do major rewrites like SDL1.2 -> SDL2.0 work? Somebody just hacks a SDL-2 version of the codebase and submits it here? Incrementally in trunk? A special branch for many people to work with? Other?

SirVer (sirver) wrote :

Whatever works :). Having a branch is definitively a start. Having something that is kept up to date with trunk is also important. Most important though, we should only start this when we are positive that we want it to happen now, i.e. when SDL 2.0 is stable enough. I have no data on this, so I feel I can not really decide when this is the case.

Teppo Mäenpää (kxq) wrote :

I think that SDL 2 dependent code should not go to trunk until the major distributions have the library in their stable branches. Working could start earlier. Working too early has the price that one needs to merge, merge and remerge trunk to the "SDL2" branch while waiting and resolve conflicts now and then.

SirVer (sirver) wrote :

Setting to incomplete for bug sweeping.

Changed in widelands:
status: Confirmed → Incomplete
GunChleoc (gunchleoc) on 2015-11-07
Changed in widelands:
status: Incomplete → Confirmed
GunChleoc (gunchleoc) on 2016-05-02
Changed in widelands:
milestone: build19-rc1 → none
Notabilis (notabilis27) on 2017-12-15
Changed in widelands:
status: Confirmed → Fix Committed
GunChleoc (gunchleoc) on 2017-12-16
Changed in widelands:
milestone: none → build20-rc1
GunChleoc (gunchleoc) wrote :

Fixed in build20-rc1

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints