buildcosts and "wares that get recycled" preview moves the window

Bug #1090887 reported by Nasenbaer on 2012-12-16
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
widelands
High
Gabriel Margiani

Bug Description

If you want to dismantle a building, you click on the building and than click on the dismantle button in the building window. But due to the new feature of showing the wares that will be recycled through the dismantling of the building, the window will move, if it is close to the main windows bottom. Similar problems appear in the construct building window.

This leads to false clicks and can be very disturbing.

I suggest to take care about the needed space in the initial window and thus avoid the resizing. in case of the building window the space and thus the resources recycled could be shown above the buttons, in case of the construct building window, the list of wares could stay were it is, but the space could be initialized as well.

Related branches

Shevonar (shevonar) wrote :

It is not a duplicate of bug #1019585 but the problem described here is also mentioned there in the comments. If this bug gets fixed in the suggested way #1019575 can also be closed.

Shevonar (shevonar) wrote :

The second number should of course also be bug #1019585.

Nasenbaer (nasenbaer) on 2013-01-19
summary: - New "show wares that are recycled" feature moves window
+ buildcosts and "wares that get recycled" preview moves the window
Gabriel Margiani (gamag) on 2013-01-19
Changed in widelands:
assignee: nobody → Gabriel Margiani (gamag)
SirVer (sirver) wrote :

Merged Gabriels work in r6495. He found a nice solution of moving the data to the tooltip: The window is never wasting space but also doesn't need to get resized.

Changed in widelands:
status: Confirmed → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers