Undefined identifiers used

Bug #1033216 reported by Hans Joachim Desserud on 2012-08-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Low
Unassigned

Bug Description

Enabling -Wundef option in GCC will warn about the following lines:
/home/arch/widelands/src/i18n.cc:31:5: warning: "__APPLE__" is not defined [-Wundef]
/home/arch/widelands/src/i18n.cc:34:7: warning: "_WIN32" is not defined [-Wundef]
/home/arch/widelands/src/wlapplication.cc:919:7: warning: "WIN32" is not defined [-Wundef]
/home/arch/widelands/src/wlapplication.cc:981:7: warning: "WIN32" is not defined [-Wundef]
/home/arch/widelands/src/wlapplication.cc:983:7: warning: "__APPLE__" is not defined [-Wundef]
/home/arch/widelands/src/wlapplication.cc:1624:5: warning: "WIN32" is not defined [-Wundef]

From checking a few, I guess it doesn't like that these lines use #if instead of #ifdef.

If we do decide to change these, we should probably coordinate it so that we can get people on the platforms in question to test whether things still work as intended afterwards.

description: updated
Nasenbaer (nasenbaer) wrote :

Jepp you are likely right with #if vs #ifdef

I further want to note, that _WIN32 should be replaced by WIN32 :)

Nasenbaer (nasenbaer) on 2012-08-29
Changed in widelands:
status: New → Fix Committed
milestone: none → build18-rc1
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers