Connection lost after some time if all players pause in multiplayer

Bug #1027058 reported by Johannes Ebke on 2012-07-20
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

In a two-player direct IP game over the internet (bzr6417), we observed that when both players pause the game (for example for dinner), the connection silently drops after some time.

This is probably since a widelands-ping is only sent if one of the clients forces a wait, but not if the players agree to pause. I will push a fix momentarily, which however has only been tested locally yet.

Related branches

Nasenbaer (nasenbaer) wrote :

Oh you are right, haven't thought about the "normal" case, when implementing the forcedPause fix :-D
Thank you for the patch!

Changed in widelands:
status: New → Confirmed
milestone: none → build18-rc1
Shevonar (shevonar) wrote :

When you think your fix is complete you should propose your branch for merging ;) I could do it for you, but you have to know when you are ready.

Shevonar (shevonar) wrote :

The branch was merged in revision 6421, so I am setting this to "Fix Committed".

Changed in widelands:
status: Confirmed → Fix Committed
importance: Undecided → Medium
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers