Crash in Build Cost Preview in Observer Mode

Bug #1024549 reported by Johannes Ebke on 2012-07-13
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
widelands
Undecided
Unassigned

Bug Description

In observer mode, clicking on an empty node (bringing up a menu) causes a segfault in trunk 6416.

Tracing this back leads to src/wui/fieldaction.cc:288, where the build cost preview is initialized. Since m_plr is NULL for an observer, the deref m_plr->tribe() leads to a segfault.

Fix following shortly.

Related branches

Johannes Ebke (ebke) wrote :
Jens Beyer (qcumber-some) wrote :

Also happens in 6417, so it's not caused by the cppcheck fixes which broke soldiers ;-)

SirVer (sirver) wrote :

Thanks Johannes! I merged your fix and added you to the list of contributors.

Changed in widelands:
status: New → Fix Committed
milestone: none → build18-rc1
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments