CrossPlatform Path fix: remove ":" in path names on Windows

Bug #1020736 reported by Nasenbaer on 2012-07-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
Medium
Unassigned

Bug Description

In the logs of my dedicated server I found some error messages, that Widelands was unable to write a saved game file on the client side. It seemed that this error was based upon the ":" in the saved game name - valid on unix filesystems, but invalid on Windows.

Because of that, the function that fixes paths send via network ( "\" vs. "/" until now) should replace the ":" as well on Windows.

Nasenbaer (nasenbaer) wrote :

fixed in rev. 6409

Changed in widelands:
status: Confirmed → Fix Committed
assignee: nobody → Nasenbaer (nasenbaer)
Nasenbaer (nasenbaer) on 2013-07-31
Changed in widelands:
assignee: Nasenbaer (nasenbaer) → nobody
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers