The stock plot is quite wrong

Bug #1016104 reported by SirVer on 2012-06-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
widelands
High
Borim

Bug Description

The newly added wares-over-time plot seems to be quite wrong. The attached screenshot shows the plot for wheat and wares-in-all-warehoses (stock to this time was < 10 and it was never > 50). The plot shows a peak of 300.

Borim, I assign you because you have made the feature, you will likely be able to track down the bug.

Related branches

SirVer (sirver) wrote :
Shevonar (shevonar) wrote :

Just to have asked: Could it be that the plot shows all wares (on roads, in buildings, on stock, ...) and not just the wares on stock?

>Just to have asked: Could it be that the plot shows all wares (on roads,
>in buildings, on stock, ...) and not just the wares on stock?
Could be, but even so: we just played for 30 minutes with a standard HQ,
no chance we ever had > 100 wheat.

Jens Beyer (qcumber-some) wrote :

Can be reproduced easily:

Start new game, don't build anything, open the statistics window.

Increase game speed and wait until 15min game time have been played.
See the time scale increase to the next stepping (I believe 30 minutes), while the number of wares gets doubled.

I guess there's some re-calculation on time-scale change. But it's not that easy, because if you use the slider to show only a limited time scale of 15 minutes, the number gets reset to the correct value again.

Borim (borim) wrote :

This is a nice greeting after my vacation, of course I will look after the bug.

Changed in widelands:
status: Confirmed → In Progress
SirVer (sirver) wrote :

Borim: Nothing better to get back into the grind by fixing a bug and too. Hope your vacation has been nice!

Borim (borim) wrote :

Yeah the vacation was nice, but too short ;)
By the way, a bug fix is uploaded.

SirVer (sirver) wrote :

Merged in 6408. Thanks Borim!

Changed in widelands:
status: In Progress → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers