Massive memory leak after closing stats window when OpenGL rendering enabled. Was: game crash and system hang - randomly

Bug #1008861 reported by RJ on 2012-06-05
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
widelands
High
Unassigned
widelands (Arch Linux)
Fix Released
Undecided
Unassigned

Bug Description

When I play winelands (campaign) game (and os) randomly hangs with no response from mouse and keybord. After system and game hang I can only do hard reset. Computer works very stable on any other app / game.
More info about system:
OS: BridgeLinux (based on ArchLinux)
Kernel: Linux 3.3.7-1-ARCH #1 SMP PREEMPT Mon May 21 22:39:59 UTC 2012 i686 GNU/Linux
Grafic drivers: nvidia 295.53
WideLands version: build-17(Relase) (from official arch repo), lang: polish, 1024x768px, Windowed mode, music off; opengl on
Every crash happen on campaign (last on atlantis 1st mission after about 2h).
Unfortunatelly I haven't last errors from ~/.xsession-errors, but yesterday when I browse this file, ends with something like that:
TI(187486): destination disappeared or economy mismatch -> fail
TI(187420): destination disappeared or economy mismatch -> fail
TI(187402): destination disappeared or economy mismatch -> fail
TI(187978): destination disappeared or economy mismatch -> fail
TW(154753): destination disappeared or economy mismatch -> fail

Issiue is very annoying, game is unplayable.
P.S. Sorry for my bad english.

RJ (nerio) on 2012-06-05
description: updated

Is this only in fullscreen or also in Window Mode? Does OpenGL
(options->advanced->OpenGL) change anything? This is the first time I
hear about widelands being unstable, therefore I wonder if something
else might be involved here.

  status incomplete

Changed in widelands:
status: New → Incomplete

I have noticed similar behaviour. What happens in my case is this:

- I play barbarians, any multiplayer map over LAN
- I open statistics window
- I watch all "general" statistics graphs
- I close the statistics window
- THEN (only *after* I have *closed* the statistics window), widelands embarks on a memory rampage, freezing my OS when it fills all available RAM.

Before closing the OS, it uses a constant amount of RAM, typically around 700 MB.

I use build 17 on an up-to-date Arch linux distribution. The problem does NOT occur if I disable opengl rendering from the command line.

$ uname -a
Linux brentjenslaptop 3.4.7-1-ARCH #1 SMP PREEMPT Sun Jul 29 22:02:56 CEST 2012 x86_64 GNU/Linux

$ ldd `which widelands`
 linux-vdso.so.1 (0x00007fffbd79c000)
 libSDL-1.2.so.0 => /lib/libSDL-1.2.so.0 (0x00007f6b3e371000)
 libpthread.so.0 => /lib/libpthread.so.0 (0x00007f6b3e155000)
 libSDL_image-1.2.so.0 => /lib/libSDL_image-1.2.so.0 (0x00007f6b3df38000)
 libSDL_mixer-1.2.so.0 => /lib/libSDL_mixer-1.2.so.0 (0x00007f6b3dce9000)
 libSDL_net-1.2.so.0 => /lib/libSDL_net-1.2.so.0 (0x00007f6b3dae4000)
 libSDL_ttf-2.0.so.0 => /lib/libSDL_ttf-2.0.so.0 (0x00007f6b3d8dd000)
 libSDL_gfx.so.13 => /lib/libSDL_gfx.so.13 (0x00007f6b3d6c5000)
 liblua.so.5.1 => /lib/liblua.so.5.1 (0x00007f6b3d499000)
 libpng15.so.15 => /lib/libpng15.so.15 (0x00007f6b3d26c000)
 libz.so.1 => /lib/libz.so.1 (0x00007f6b3d056000)
 libGL.so.1 => /lib/libGL.so.1 (0x00007f6b3cd3b000)
 libGLEW.so.1.8 => /lib/libGLEW.so.1.8 (0x00007f6b3caba000)
 libstdc++.so.6 => /lib/libstdc++.so.6 (0x00007f6b3c7b7000)
 libm.so.6 => /lib/libm.so.6 (0x00007f6b3c4bd000)
 libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007f6b3c2a8000)
 libc.so.6 => /lib/libc.so.6 (0x00007f6b3bf04000)
 libdl.so.2 => /lib/libdl.so.2 (0x00007f6b3bd00000)
 /lib/ld-linux-x86-64.so.2 (0x00007f6b3e60b000)
 libfreetype.so.6 => /lib/libfreetype.so.6 (0x00007f6b3ba62000)
 libbz2.so.1.0 => /lib/libbz2.so.1.0 (0x00007f6b3b852000)
 libnvidia-tls.so.302.17 => /lib/libnvidia-tls.so.302.17 (0x00007f6b3b64f000)
 libnvidia-glcore.so.302.17 => /lib/libnvidia-glcore.so.302.17 (0x00007f6b3929e000)
 libX11.so.6 => /lib/libX11.so.6 (0x00007f6b38f65000)
 libXext.so.6 => /lib/libXext.so.6 (0x00007f6b38d52000)
 libXmu.so.6 => /lib/libXmu.so.6 (0x00007f6b38b38000)
 libXi.so.6 => /lib/libXi.so.6 (0x00007f6b38929000)
 libGLU.so.1 => /lib/libGLU.so.1 (0x00007f6b386bb000)
 libxcb.so.1 => /lib/libxcb.so.1 (0x00007f6b3849d000)
 libXt.so.6 => /lib/libXt.so.6 (0x00007f6b38237000)
 libXau.so.6 => /lib/libXau.so.6 (0x00007f6b38033000)
 libXdmcp.so.6 => /lib/libXdmcp.so.6 (0x00007f6b37e2d000)
 libSM.so.6 => /lib/libSM.so.6 (0x00007f6b37c25000)
 libICE.so.6 => /lib/libICE.so.6 (0x00007f6b37a09000)
 libuuid.so.1 => /lib/libuuid.so.1 (0x00007f6b37804000)

Changed in widelands:
status: Incomplete → Confirmed
status: Confirmed → Incomplete
Changed in widelands:
status: Incomplete → Confirmed
summary: - game crash and system hang - randomly
+ Massive memory leak after closing stats window when OpenGL rendering
+ enabled. Was: game crash and system hang - randomly

Extra info: I use the xmonad window manager under XFCE 4.10.

And I always run full screen. Don't know yet what happens in windowed mode.

Nasenbaer (nasenbaer) on 2012-08-04
Changed in widelands:
importance: Undecided → High
milestone: none → build18-rc1
LaunchPeter (launchpeter) wrote :

I have simmilar problem. If it is not the same, I can open a seperate bug.

In my case the crashes seem to happen randomly (not connected with the stats windows). Happens in PvC games as well as in the campaign.

I get the message
destination disappeared or economy mismatch -> fail
and then the whole system hangs. Only a restart of the computer helps.

It happend with the last few versions from the Ubuntu-PPA. Lastly with
Widelands-bzr6473[trunk](Release)

Some system information:
Ubuntu 12.10
Linux 3.5.0-21-generic x86_64
XFCE 4.10
Nvidia-drivers 304.43
Windowed mode, music off; opengl off

SirVer (sirver) wrote :

a reliable way to reproduce this would be most welcome - otherwise this bug will be hard to track down. Savegames sometimes prior to the occurence might also help as long as this happens sometime. Note the autosave feature which might yield a suitable game just after a crash.

_aD (ad-simplypeachy) wrote :

May be related to bug 1096632

_aD (ad-simplypeachy) wrote :

Can you try to re-create the problem with the latest trunk revision? The bug I suffered, which seemed similar, is no longer affecting the game when playing revision 6567.

Changed in widelands:
status: Confirmed → Incomplete
Nasenbaer (nasenbaer) wrote :

three month since comment #8

Anyone can reproduce the bug? If not, I guess we can close this bug report

SirVer (sirver) on 2013-09-14
Changed in widelands:
status: Incomplete → Fix Committed
SirVer (sirver) wrote :

Released in build-18 rc1.

Changed in widelands:
status: Fix Committed → Fix Released
Changed in widelands (Arch Linux):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers