Does not work out of the box on Ubuntu Natty (due to numpy)

Reported by Hans Joachim Desserud on 2011-03-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Widelands Website
Medium
Unassigned

Bug Description

(note: this is probably not widelands-website's fault, but I've reported it here initially so that others are aware of the issue)
Recently I have been setting up a local version of widelands-website in a virtual machine. After some initial problems I got it to work in Ubuntu Maverick (10.10). However, when I tried to set it up in Ubuntu Natty (11.04) using the exact same steps, it failed. As far as I can see, the main issue is that numpy fails to compile for some reason.
Before starting I have pulled in the build-dependencies (using apt-get build-dep python-numpy), but when setting up the website it fails when compiling numpy.

Differences between Maverick and Natty:
1. Numpy version
Maverick contains 1:1.3.0-3build1, while Natty has 1:1.5.1-1ubuntu2. However, as when setting up the website, I have pulled in the upstream source code from 1.5.1 in both cases.
2. Python versions
Maverick uses python 2.6, while Natty has moved to 2.7. I don't know if this is affecting the source, but it may play an issue in the next point.
3. Numpy dependencies
When installing build-dependencies for numpy, I think the dependencies have changed. I have not compared them though, and I would also like to check what happens if I manually install the dependencies used in Maverick instead.

When I get time I'll look more into this and hopefully figure out where the problem lies, and if appropriate suggest some additions for the README or forward this bug report.

Changed in widelands-website:
importance: Undecided → Medium
janus (janus-jhor) on 2011-07-16
Changed in widelands-website:
status: New → In Progress
Hans Joachim Desserud (hjd) wrote :

I haven't checked this, so I'm not 100% sure, but I assume bug 780220 is describing the same issue. It contains some workarounds which may work.

Hans Joachim Desserud (hjd) wrote :

I haven't checked back with Ubuntu 11.04 for a while, but on 11.10 it works out of the box following the instructions in the README.

SirVer (sirver) wrote :

okay, fix committed it is then :)

Changed in widelands-website:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers