screenshot application does only scale on width

Reported by Nasenbaer on 2010-06-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Widelands Website
Medium
Unassigned

Bug Description

the screenshot application currently scales the pictures to one of the three given sizes (640 x 480 ; 800 x 600 ; 1024 x 768). If a picture is not in 4:3 format, it does only care about the width of a picture. This leads to hugh scaled pictures, if only parts of a screen are used (like the stock menu that has ~ a 3:7 format).

Because of that I suggest to:

1) Add a link "real size" - should be the default one
2) Change the code, that it scales the picture that way, that x an y are used for scaled size calculation (so in case of the stock menu it should see, that the important size is the y size and not the x size.

Shevonar (shevonar) on 2012-04-19
Changed in widelands-website:
status: Confirmed → Fix Committed
Nasenbaer (nasenbaer) on 2013-06-10
Changed in widelands-website:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints