News feed no longer available

Bug #1799652 reported by Tino on 2018-10-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Widelands Website
Undecided
Unassigned

Bug Description

Just noticed, that the Widelands News RSS feed does no longer work.
The <head> references:

   <link rel="alternate" type="application/rss+xml" title="Widelands News" href="/feeds/news/" />

I've subscribed with feedly.com and the last entry is https://wl.widelands.org/news/2018/Feb/19/schedule-your-games/ , so it broke sometime after february.

The forum feeds do still work

  <link rel="alternate" type="application/atom+xml" title="Latest Posts on all forums" href="/forum/feeds/posts/" />
  <link rel="alternate" type="application/atom+xml" title="Latest Topics on all forums" href="/forum/feeds/topics/" />

kaputtnik (franku) wrote :

Will look into this when i am back :-)

kaputtnik (franku) wrote :

The next news was added 2018-03-18, but i can't find any feed related changes between February and March. First i thought the update to Django 1.11 is the culprit, but this was done in April.

Using a feed validator shows we are having valid feeds, but most feed readers can't handle our feeds... http://validator.w3.org/feed/check.cgi?url=https%3A%2F%2Fwl.widelands.org%2Fnews%2Ffeed%2F

Currently i have no idea to improve the things which are suggested there.

Showing the news feed in Browser FF and opera works fine. Maybe feedly.com has changed something between February and March?

Tino (tino79) wrote :

Ok, the new URL does work now:
=> https://wl.widelands.org/news/feed/

When i was reporting this bug the URL in the head part was https://wl.widelands.org/feeds/new, see initial report.

Feedly does now read fine, but only shows the latest (23rd October) news.

kaputtnik (franku) wrote :

The url change was done in September, sorry for not notifying of that.

> Feedly does now read fine, but only shows the latest (23rd October) news.

As said Opening the feeds in a browser work as expected, so i guess this has something to do with Feedly. Maybe Feedly has some settings which prevent showing older feeds?

kaputtnik (franku) wrote :

Tino, what do you think about this bug?

Tino (tino79) wrote :

As far as I can see, everything is fine again.
Everything shows up on the new URL, also within Feedly.

Changed in widelands-website:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers