Email notification for comments to uploaded maps

Bug #1471662 reported by TiborB on 2015-07-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Widelands Website
Wishlist
kaputtnik

Bug Description

Hi

I would like to receive a "New post" mail notification for a comment to a map I have uploaded in widelands maps section. Exactly the way how I get mail notifications when somebody post a replay in a forum thread I have created.

Tags: map Edit Tag help
kaputtnik (franku) wrote :

Nice idea :-)

I think this is a bug for the website... so https://bugs.launchpad.net/widelands-website is the right place for this bug.

Do you want to create a new bug over there? Otherwise i will do that for you. I will change this bug to "invalid".

Changed in widelands:
status: New → Invalid
Hans Joachim Desserud (hjd) wrote :

No need to create a new bug, I simply moved this one. :)

(If you select the yellow exclamation mark next to the project name under Affects, it is posisble to change which project a bug report belongs to. Though, normally one would use "also affects" just below if the bug concerns multiple projects/packages)

affects: widelands → widelands-website
Changed in widelands-website:
status: Invalid → New
kaputtnik (franku) wrote :

Ahhh... thank you :-)

TiborB (tiborb95) wrote :

thanks guys

kaputtnik (franku) on 2015-07-14
tags: added: map
removed: website
kaputtnik (franku) on 2017-04-21
Changed in widelands-website:
assignee: nobody → kaputtnik (franku)
status: New → In Progress
kaputtnik (franku) wrote :

Looks like this not that trivial.

I'll look into this later on.

Changed in widelands-website:
status: In Progress → Confirmed
SirVer (sirver) wrote :

One think that I was considering a couple of times before is to get rid of threaddcomments dependency and make everything commentable a forum post.

I took this idea from http://www.teamliquid.net/ - if you click on any of the official news stories, you'll see that it is a fancily formatted forum post and comments are just replies to this OP.

I think it is hard to make a posted map or a news article into a forum post with our current site setup, but maybe we can create a shadow thread in a hidden forum for each map (and later news post/poll) and display that instead of the threadedcomments view.

kaputtnik (franku) wrote :

threadedcomments isn't an external dependency anymore since the upgrade to Django 1.8

Your idea sounds interesting... First i want to bring up the notifications_cleanup branch, which provides at least an email notification if a new map was uploaded. In addition i want to add a similar email notification for the news.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers