Map section: upload fails if Widelands internal map name already exists

Bug #1210606 reported by Nasenbaer on 2013-08-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Widelands Website
Medium
Shevonar

Bug Description

If you try to upload e.g. the map "XYZ" and there is already a map with said name (does not matter what the file name is or whether the two maps are identical or differ) the uploader will just behave as if no map was selected.

Either it should bail out, that there was an error and that there may not be two different maps with the same name (name uniqueness) or it should upload it and add a suffix (e.g. "XYZ [2]")

Related branches

Nasenbaer (nasenbaer) on 2013-08-09
Changed in widelands-website:
status: New → Confirmed
importance: Undecided → Medium
Shevonar (shevonar) wrote :

There is a check for the map name in the code and it should throw an error on map upload. I guess this error somehow does not show up and the upload fails silently. I am investigating.

Changed in widelands-website:
assignee: nobody → Shevonar (shevonar)
Shevonar (shevonar) wrote :

The problem was that there was simply no place in the template to show the error messages. Fix will be committed soon.

Changed in widelands-website:
status: Confirmed → In Progress
SirVer (sirver) on 2013-08-09
Changed in widelands-website:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers