Home page results in "ImportError No module named feeds" if trying to use Django 1.4.2

Bug #1088032 reported by Hans Joachim Desserud
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Widelands Website
Fix Released
Medium
kaputtnik

Bug Description

Since Django version 1.4.x has been out for a while, I thought I'd try and see what happened if I upgraded from 1.3.2 which is specified in requirements.txt to the latest version. Turns out this will raise an ImportError when trying to access the home page:
No module named feeds
/home/ubuntu/wlwebsite/code/widelands/../widelands/news/feeds.py in <module>
    from django.contrib.syndication.feeds import FeedDoesNotExist

Looks like we try to use a module which no longer exists. I have not investigated further so I don't know if it has simply been moved or if we need to find a replacement. Currently it would be blocking migrating to newer versions of Django though, which would be nice to be able to.

(Tried with Django 1.4.2)

Related branches

Revision history for this message
SirVer (sirver) wrote :

I just wished django would treat more carefully when updating... Shevona, I assigned you as you are the king of the website code right now. Feel free to unassign if you have no time.

Changed in widelands-website:
status: New → Confirmed
assignee: nobody → Shevonar (shevonar)
Revision history for this message
Shevonar (shevonar) wrote :

Fixed in my branch for django 1.4

Changed in widelands-website:
status: Confirmed → Fix Committed
kaputtnik (franku)
Changed in widelands-website:
status: Fix Committed → In Progress
assignee: Shevonar (shevonar) → kaputtnik (franku)
kaputtnik (franku)
Changed in widelands-website:
status: In Progress → Fix Released
Revision history for this message
Hans Joachim Desserud (hjd) wrote :

Great! :) Thanks for working on and updating the website to a currently supported version.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers