wicd-client displays previous connected network's essid while connects

Bug #506942 reported by Lonli-Lokli on 2010-01-13
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
wicd
Undecided
Unassigned
wicd (Arch Linux)
New
Undecided
Unassigned

Bug Description

When wicd-client connects to wireless network it display in status bar essid of last network was connected to. When connection completed essid changes to actual.

wicd 1.6.2.2 from http://apt.wicd.net
debian lenny i386

2010/01/13 15:27:13 :: Autoconnecting...
2010/01/13 15:27:13 :: No wired connection present, attempting to autoconnect to wireless network
2010/01/13 15:27:13 :: Unable to autoconnect, you'll have to manually connect
2010/01/13 15:27:18 :: Autoconnecting...
2010/01/13 15:27:18 :: No wired connection present, attempting to autoconnect to wireless network
2010/01/13 15:27:18 :: Unable to autoconnect, you'll have to manually connect
2010/01/13 15:27:23 :: Autoconnecting...
2010/01/13 15:27:23 :: No wired connection present, attempting to autoconnect to wireless network
2010/01/13 15:27:24 :: hidden
2010/01/13 15:27:24 :: hidden
2010/01/13 15:27:24 :: hidden
2010/01/13 15:27:24 :: trying to automatically connect to...evilnet
2010/01/13 15:27:24 :: Connecting to wireless network evilnet
2010/01/13 15:27:24 :: Putting interface down
2010/01/13 15:27:24 :: Releasing DHCP leases...
2010/01/13 15:27:24 :: Setting false IP...
2010/01/13 15:27:24 :: Stopping wpa_supplicant
2010/01/13 15:27:24 :: Flushing the routing table...
2010/01/13 15:27:24 :: Putting interface up...
2010/01/13 15:27:24 :: Generating psk...
2010/01/13 15:27:25 :: Attempting to authenticate...
2010/01/13 15:27:27 :: Running DHCP
2010/01/13 15:27:27 :: Internet Systems Consortium DHCP Client V3.1.1
2010/01/13 15:27:27 :: Copyright 2004-2008 Internet Systems Consortium.
2010/01/13 15:27:27 :: All rights reserved.
2010/01/13 15:27:27 :: For info, please visit http://www.isc.org/sw/dhcp/
2010/01/13 15:27:27 ::
2010/01/13 15:27:28 :: Listening on LPF/wlan0/00:15:af:b5:5c:11
2010/01/13 15:27:28 :: Sending on LPF/wlan0/00:15:af:b5:5c:11
2010/01/13 15:27:28 :: Sending on Socket/fallback
2010/01/13 15:27:28 :: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
2010/01/13 15:27:30 :: DHCPOFFER from 192.168.0.1
2010/01/13 15:27:30 :: DHCPREQUEST on wlan0 to 255.255.255.255 port 67
2010/01/13 15:27:30 :: DHCPACK from 192.168.0.1
2010/01/13 15:27:30 :: bound to 192.168.0.3 -- renewal in 99058 seconds.
2010/01/13 15:27:30 :: DHCP connection successful
2010/01/13 15:27:30 :: Connecting thread exiting.
2010/01/13 15:27:30 :: Sending connection attempt result Success
2010/01/13 15:33:04 :: hidden
2010/01/13 15:33:05 :: hidden
2010/01/13 15:33:06 :: hidden

Neuman Vong (neumanv) wrote :

This is happening for me too on Debian Squeeze with wicd-gtk 1.7.0+ds1-.

Adam Blackburn (adamblackburn) wrote :

This is a known bug and doesn't have an easy fix. It shouldn't affect the functionality, though.

Changed in wicd:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers