Wishlist: iwconfig rate setting

Bug #491449 reported by Anders on 2009-12-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wicd
Medium
David Paleino

Bug Description

When connecting to a particular, weak wifi network using Wicd in Ubuntu 9.10 ("Karmic"), the default iwconfig rate setting is too high and it prevents a successful connection (IP address obtained, but no network traffic allowed).

If i create a small script in if-pre-up.d, I can override the default with the command "iwconfig rate 5.5M auto" but it seems only partially successful / only to work part of the time.

It would be "wicked" if wicd would support an "advanced settings" property box on a network-by-network or interface-by-interface basis to allow misc iwconfig settings to be overridden.

Other references:
http://www.cyberciti.biz/faq/setting-up-an-network-interfaces-file/

Related request:
http://wicd.net/punbb/viewtopic.php?id=553

Related branches

David Paleino (dpaleino) on 2011-09-18
Changed in wicd:
status: New → Triaged
importance: Undecided → Medium
David Paleino (dpaleino) on 2012-02-05
Changed in wicd:
milestone: none → 1.7.2
assignee: nobody → David Paleino (dpaleino)
David Paleino (dpaleino) on 2012-04-11
Changed in wicd:
milestone: 1.7.2 → 1.7.3
David Paleino (dpaleino) on 2012-05-03
Changed in wicd:
status: Triaged → In Progress
David Paleino (dpaleino) wrote :

Fixed in rev813.

Changed in wicd:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers