wicd-client does not work in Malayalam locale

Bug #407424 reported by Praveen Arimbrathodiyil on 2009-07-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wicd
Low
Dan O'Reilly

Bug Description

$ wicd-client
unknown locale: ml_IN
Default locale unavailable, falling back to en_US
Traceback (most recent call last):
  File "/usr/share/wicd/wicd-client.py", line 60, in <module>
    from wicd import gui
  File "/usr/share/wicd/wicd/gui.py", line 38, in <module>
    from wicd import prefs
  File "/usr/share/wicd/wicd/prefs.py", line 42, in <module>
    from translations import language
  File "/usr/share/wicd/wicd/translations.py", line 59, in <module>
    _ = get_gettext()
  File "/usr/share/wicd/wicd/translations.py", line 50, in get_gettext
    if (lc):
UnboundLocalError: local variable 'lc' referenced before assignment

It used to work just fine before I updated to 1.6.1 (same error in 1.6.2 as well). Other locales (hi_IN, ta_IN) work just fine. LANG=ml wicd-client also does not work.

Changed in wicd:
importance: Undecided → Low
milestone: none → 1.6.3
Dan O'Reilly (oreilldf) on 2009-08-02
Changed in wicd:
status: New → In Progress
assignee: nobody → Dan O'Reilly (oreilldf)
Adam Blackburn (adamblackburn) wrote :

I believe this was fixed in revision 447.

Changed in wicd:
status: In Progress → Fix Committed
Changed in wicd:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers