wicd-client freezes after clicking connect button

Bug #381141 reported by cpwatson on 2009-05-28
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
wicd
Undecided
Unassigned

Bug Description

Step 1: Start wicd daemon. Everything is normal

Step 2: Start wicd-client. Available networks are listed. Everything is normal.

Step 3: Click "Connect" on a network.

wicd.log shows the connection process happening, but the gui absolutly freezes. The network connects and the gui remains entirly unresponsive. The output for the gui is only the list of available networks. Cannot Ctrl-C from the command line to close it. wicd-client jumps to 100% CPU usage and eats all available RAM.

If you kill the wicd-client and start it again all is well until you click on "Connect" again

If you run wicd-client as root, works normally, so my best guess is it is a permission problem.

groups:
wheel games avahi network video audio optical storage power dbus (my user name)

Arch Linux 32-bit

Linux version 2.6.29-ARCH (root@T-POWA-LX) (gcc version 4.3.3 (GCC) ) #1 SMP PREEMPT Wed Apr 8 12:47:56 UTC 2009

wicd version - 1.5.9
python version - 2.6.2-1
dbus - 1.2.4permissive-1

wicd-log:
2009/05/27 20:08:03 :: ---------------------------
2009/05/27 20:08:03 :: wicd initializing...
2009/05/27 20:08:03 :: ---------------------------
2009/05/27 20:08:03 :: Automatically detected wireless interface wlan0
2009/05/27 20:08:03 :: found wireless_interface in configuration wlan0
2009/05/27 20:08:03 :: setting wireless interface wlan0
2009/05/27 20:08:03 :: automatically detected wired interface eth0
2009/05/27 20:08:03 :: found wired_interface in configuration eth0
2009/05/27 20:08:03 :: setting wired interface eth0
2009/05/27 20:08:03 :: found wpa_driver in configuration wext
2009/05/27 20:08:03 :: setting wpa driver wext
2009/05/27 20:08:03 :: found always_show_wired_interface in configuration False
2009/05/27 20:08:03 :: found use_global_dns in configuration False
2009/05/27 20:08:03 :: setting use global dns to False
2009/05/27 20:08:03 :: setting use global dns to boolean False
2009/05/27 20:08:03 :: found global_dns_1 in configuration None
2009/05/27 20:08:03 :: found global_dns_2 in configuration None
2009/05/27 20:08:03 :: found global_dns_3 in configuration None
2009/05/27 20:08:03 :: setting global dns
2009/05/27 20:08:03 :: global dns servers are None None None
2009/05/27 20:08:03 :: found auto_reconnect in configuration True
2009/05/27 20:08:03 :: setting automatically reconnect when connection drops
2009/05/27 20:08:03 :: found debug_mode in configuration 0
2009/05/27 20:08:03 :: found wired_connect_mode in configuration 1
2009/05/27 20:08:03 :: found signal_display_type in configuration 0
2009/05/27 20:08:03 :: found dhcp_client in configuration 1
2009/05/27 20:08:03 :: Setting dhcp client to 1
2009/05/27 20:08:03 :: found link_detect_tool in configuration 0
2009/05/27 20:08:03 :: found flush_tool in configuration 2
2009/05/27 20:08:03 :: Wireless configuration file found...
2009/05/27 20:08:03 :: Wired configuration file found...
2009/05/27 20:08:03 :: chmoding configuration files 0600...
2009/05/27 20:08:03 :: chowning configuration files root:root...
2009/05/27 20:08:03 :: Using wired interface...eth0
2009/05/27 20:08:03 :: Using wireless interface...wlan0
2009/05/27 20:08:03 :: autoconnecting... wlan0
2009/05/27 20:08:12 :: Putting interface downAttempting to autoconnect with wired interface...
2009/05/27 20:08:12 ::
2009/05/27 20:08:12 :: Releasing DHCP leases...
2009/05/27 20:08:13 :: Setting false IP...
2009/05/27 20:08:13 :: Stopping wpa_supplicant and any DHCP clients
2009/05/27 20:08:13 :: Flushing the routing table...
2009/05/27 20:08:13 :: Putting interface up...
2009/05/27 20:08:13 :: Running DHCP
2009/05/27 20:08:13 :: Internet Systems Consortium DHCP Client V3.0.6
2009/05/27 20:08:13 :: Copyright 2004-2007 Internet Systems Consortium.
2009/05/27 20:08:13 :: All rights reserved.
2009/05/27 20:08:13 :: For info, please visit http://www.isc.org/sw/dhcp/
2009/05/27 20:08:13 ::
2009/05/27 20:08:13 :: wmaster0: unknown hardware address type 801
2009/05/27 20:08:14 :: wmaster0: unknown hardware address type 801
2009/05/27 20:08:14 :: Listening on LPF/eth0/00:15:c5:7f:66:a5
2009/05/27 20:08:14 :: Sending on LPF/eth0/00:15:c5:7f:66:a5
2009/05/27 20:08:14 :: Sending on Socket/fallback
2009/05/27 20:08:15 :: DHCPREQUEST on eth0 to 255.255.255.255 port 67
2009/05/27 20:08:23 :: DHCPREQUEST on eth0 to 255.255.255.255 port 67
2009/05/27 20:08:23 :: DHCPACK from 129.25.1.10
2009/05/27 20:08:23 :: bound to 129.25.22.142 -- renewal in 687698 seconds.
2009/05/27 20:08:23 :: DHCP connection successful
2009/05/27 20:08:23 :: Connecting thread exiting.
2009/05/27 20:08:43 :: Connecting to wireless network dragonfly3
2009/05/27 20:08:43 :: Putting interface down
2009/05/27 20:08:43 :: Releasing DHCP leases...
2009/05/27 20:08:43 :: Setting false IP...
2009/05/27 20:08:43 :: Stopping wpa_supplicant and any DHCP clients
2009/05/27 20:08:43 :: Flushing the routing table...
2009/05/27 20:08:43 :: Attempting to authenticate...
2009/05/27 20:08:44 :: Putting interface up...
2009/05/27 20:08:48 :: wpa_supplicant rescan forced...
2009/05/27 20:08:52 :: wpa_supplicant rescan forced...
2009/05/27 20:09:34 :: wpa_supplicant authentication may have failed.
2009/05/27 20:09:34 :: exiting connection thread
2009/05/27 20:09:39 :: Putting interface down
2009/05/27 20:09:39 :: Attempting to autoconnect with wired interface...
2009/05/27 20:09:39 :: Releasing DHCP leases...
2009/05/27 20:09:39 :: Setting false IP...
2009/05/27 20:09:39 :: Stopping wpa_supplicant and any DHCP clients
2009/05/27 20:09:39 :: Flushing the routing table...
2009/05/27 20:09:39 :: Putting interface up...
2009/05/27 20:09:39 :: Running DHCP
2009/05/27 20:09:39 :: Internet Systems Consortium DHCP Client V3.0.6
2009/05/27 20:09:39 :: Copyright 2004-2007 Internet Systems Consortium.
2009/05/27 20:09:39 :: All rights reserved.
2009/05/27 20:09:39 :: For info, please visit http://www.isc.org/sw/dhcp/
2009/05/27 20:09:39 ::
2009/05/27 20:09:39 :: wmaster0: unknown hardware address type 801
2009/05/27 20:09:40 :: wmaster0: unknown hardware address type 801
2009/05/27 20:09:40 :: Listening on LPF/eth0/00:15:c5:7f:66:a5
2009/05/27 20:09:40 :: Sending on LPF/eth0/00:15:c5:7f:66:a5
2009/05/27 20:09:40 :: Sending on Socket/fallback
2009/05/27 20:09:40 :: DHCPREQUEST on eth0 to 255.255.255.255 port 67
2009/05/27 20:09:48 :: DHCPREQUEST on eth0 to 255.255.255.255 port 67
2009/05/27 20:09:48 :: DHCPACK from 129.25.1.10
2009/05/27 20:09:48 :: bound to 129.25.22.142 -- renewal in 864661 seconds.
2009/05/27 20:09:48 :: DHCP connection successful
2009/05/27 20:09:48 :: Connecting thread exiting.

Dan O'Reilly (oreilldf) wrote :

Very strange, especially since it works when you run it as root. wicd-client is designed to be run without any root privileges, so I don't think permissions are playing any role. Do you think you could see if this reproduces with v1.6.0b3? At this point all of our development efforts have shifted from 1.5.x to 1.6.0.

junmin (tcwork) wrote :

found the cause. here it's because of the aurora gtk engine. you would want to change the gtk theme.

Adam Blackburn (adamblackburn) wrote :

This is not a bug in Wicd.

Changed in wicd:
status: New → Invalid
mescalinum (mescalinum) wrote :

still a problem with 1.6.2

how this is not a wicd problem? I use tons of apps everyday, and only wicd has this issue with the aurora engine

Zveroy (zveroy) wrote :

wicd-gtk 1.7.0 Bug still here. Only wicd-gtk show this behavior with Aurora engine.

Changed in wicd:
status: Invalid → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers