Missing important feature - Security Key Index value

Bug #339435 reported by Dan Sosedoff on 2009-03-08
10
Affects Status Importance Assigned to Milestone
wicd
Wishlist
David Paleino
Declined for 2.0 by Adam Blackburn

Bug Description

Ok, here is the info:

OS: Ubuntu 8.04
Wireless network secured by 128 bit wep key. Key index value changed to 4 (default is 1). This feature available in windows operating systems, but missing in all linux network managers. So, i`m currently using self-made shell scripts to connect to wifi.
I also tried to connect with different parameters, but still no results.

I guess it`s not very hard to implement (additional checkbox in parameters), but will be very useful for users who not proficient in shell scripting.

Thanks.

Related branches

Dan O'Reilly (oreilldf) wrote :

I think you should be able to create a encryption template to connect to the correct network. Open up /etc/wicd/encryption/templates/wep-hex, and find the lines that say:
wep_key0=$_KEY
wep_tx_keyidx=0

I think if you change those 0's to 3 (or possible 4), you should be able to connect.

I do agree though, it should be possible to make this change in the GUI.

Changed in wicd:
importance: Undecided → Wishlist
status: New → Triaged
Adam Blackburn (adamblackburn) wrote :

Targeting for Wicd 2.0 (aqua)

Changed in wicd:
milestone: none → aqua-alpha-1
David Paleino (dpaleino) on 2012-02-05
Changed in wicd:
milestone: 2.0 → 1.7.2
assignee: nobody → David Paleino (dpaleino)
David Paleino (dpaleino) on 2012-04-11
Changed in wicd:
milestone: 1.7.2 → 1.7.3
David Paleino (dpaleino) on 2012-05-03
Changed in wicd:
status: Triaged → Invalid
status: Invalid → In Progress
David Paleino (dpaleino) on 2012-05-04
Changed in wicd:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers