Wishlist: Allow extra options for wpa_supplicant to be specified

Bug #311157 reported by Zsolt Dollenstein on 2008-12-24
2
Affects Status Importance Assigned to Milestone
wicd
Wishlist
Unassigned
Declined for 1.6 by Adam Blackburn

Bug Description

The reason I am using wicd is because I had no luck with NetworkManager getting to connect to wireless networks protected by wpa. During my research I have found that when running wpa_supplicant interactively (i.e. specifying -d and removing -B flag) it is able to connect to the network. I traced the problem to some timing issue between wpa_supplicant and the wifi card driver. The relevant thing is that if wpa_supplicant gets run with a low nice value (I'm using -19), it just works. This got me to changing /usr/lib/python2.5/site-packages/wicd/wnettools.py line 856.
It would be nice if there would be an (advanced) option that describes how to launch these tools, or at least to be able to specify extra options (like -d) to them.

Wicd 1.5.6
Ubuntu 8.10

Zsolt Dollenstein (zsol) on 2008-12-24
description: updated
Changed in wicd:
importance: Undecided → Wishlist
status: New → Triaged
Adam Blackburn (adamblackburn) wrote :

Targeting for Wicd 2.0 (aqua).

Changed in wicd:
milestone: none → aqua-alpha-1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers