WICD 1.5.0 asks for password at startup

Bug #250197 reported by jackal on 2008-07-20
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
wicd
Undecided
Unassigned

Bug Description

On start up WICD 1.5.0 asks for a password to access the network cards. The version before didn't ask for this. Maybe if you can't get rid of it you should make it so the password is remembered.

Dan O'Reilly (oreilldf) wrote :

This shouldn't happen. For some reason the daemon isn't starting up with your computer. Do you have a Sessions autostart entry from 1.4.2 hanging around? If so, delete it. What method did you use to install 1.5.0?

Adam Blackburn (adamblackburn) wrote :

Sounds like the init file doesn't exist.

What distro are you on, and how did you install Wicd?

Changed in wicd:
status: New → Incomplete

Ubuntu 8.04 I installed it from the .deb package on the website. I had 1.4.2 installed before. How do i remove the auto start entry.

Adam Blackburn (adamblackburn) wrote :

System -> Preferences -> Sessions and then find the Wicd entry and uncheck the box.

Adam Blackburn (adamblackburn) wrote :

Also, can you run

ls /var/log/wicd

Thanks :)

I unticked all WICD. And when I run ls /var/log/wicd I get this:

alistair@alistairs-laptop:~$ ls /var/log/wicd
wicd.log

I still have to enter my password. How can i fix it?

Dan O'Reilly (oreilldf) wrote :

Try running this command:
sudo update-rc.d wicd start 80 2 3 4 5 . stop 20 0 1 6 .

And see if the daemon starts up at boot then.

That didn't work

Wing (wing) wrote :

I am having the same problem on Ubuntu 8.0.4.

First, I used the Synaptic Package Manager to install the 1.4.2 and then I downloaded and installed the 1.5.1 from SourceForge.net manually.

I also tried all mentioned from previous posts
ls command returned wicd.log file
sudo update command returned "System startup links for /etc/init.d/wicd already exist." message.

Besides, the Trap Icon won't start automatically. I have to use Alt-F2 and type "wicd-client" to have it loaded.

Right now, it won't allow me to remove or reinstall wicd. Any help would be appreciated.

Thanks!

gerben (gerben-rotman) wrote :

Same problem here.

I upgraded from wicd 1.4.2, using wicd_1.5.1_all.deb. I did nothing special just double clicked it and let it install it installed without errors or warnings.

When I boot my computer I am asked for the root password after I have logged in. A dialog pops up with this text:
"Wicd needs to access your computer's network cards"
underneath is a box where I can enter the password, after I give it the root password, the internet connection is working, but there is no tray icon even though wicd-client has automatically been added to session startup. If I then run wicd-client from the Terminal I get the tray icon.

***
following Adam's suggestion gives:

gerben@gerben-laptop:~$ sudo update-rc.d wicd start 80 2 3 4 5 . stop 20 0 1 6 .
System startup links for /etc/init.d/wicd already exist.

gerben (gerben-rotman) wrote :

Sorry forgot to mention:
I am using Ubuntu 8.04 hardy heron.

gerben (gerben-rotman) wrote :

In my case the cause of the problem was that I still had the old /etc/int.d/wicd script, as in the one from the previous version 1.4.2

The problem seems to be solved by opening the wicd_1.5.1_all.deb file in archive manager, then open the etc/init.d/wicd script that is in the .deb file and copy its contents over the contents of the /etc/init.d/wicd script that is on the hard drive.

It appears to be working fine now, when I log in I'm already connected to my prefered wireless network and the tray icon is loaded.

No clue why it did not install that file properly when installing wicd_1.5.1_all.deb

NJLG (noahjlg) wrote :

Thanks Gerben, that worked.

I believe the problem occurs depending on how you install. On one system, i removed the old WICD version completely then installed 1.5.1. This worked with no problems. On a second system (the one I was having trouble with) I installed 1.5.1 over 1.4.2. I remember it asking, during install, whether to overwrite some scripts and i guess i said no for the /etc/init.d/wicd script.

Copying the file from the .deb to the init.d directory worked perfectly.

Robby Workman (rworkman) wrote :

Marking as invalid to close it.

Changed in wicd:
status: Incomplete → Invalid
Youri (i-bis) wrote :

Something like that happen to me too :

I'm trying to use wicd 1.6.2.2 on Ubuntu Karmic koala 64 on an Acer aspire 9300 wlmi

At boot Wicd is asking for my root password and then it display the folowing messages :

"Could not connect to wicd's D-Bus interface. Check the wicd log for error messages."
and then it say that the tray-icon wont work properly till i reboot wicd-client
After I type my password Wicd autoconnect properly even if the tray-icon is not working...to make it working i just have to do Alt+F2 ---> "wicd-client" and then everything goes well but it's annoying to do it at every boot :(

The eror message in /var/log/wicd/wicd.log is :
"dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: Connection ":1.39" is not allowed to own the service "org.wicd.daemon" due to security policies in the configuration file"
(I'm in the "netdev" group so it's not supposed to happen...)

I already reinstalled it 3 or 4 times, i event downgraded it to 1.6.0 ( i tried with synaptic from the wicd repository and i tried also the .deb that i download from the official website..) but it still don't work correctly :(

I can try to find more details if needed

1wang (1wang) wrote :

I have a solution :
My ubuntu 9.10 studio installation came without network manager. Because I had problems with network manager and WPA on earlier ubuntu versions I decided to give wicd a try. At first it worked well without problems. But suddenly since a few days after some Software Updates I don't remember so well I had the same problem: "Wicd needs to access your computer's network cards" asking for the root password. In /var/log/wicd/wicd.log I had ConfigParser.ParsingError: File contains parsing errors: /etc/wicd/wired-settings.conf [line 23]: '[]\n' With an editor I saw there were square brackets at the end of the file which I had't put there. After removing them the above problem vanishd, but networks connections are still not established. I found out the wicd setup files under /etc/wicd/ have been replaced by some almost empty default. The setup has to be done again.

colinnwn (colin-thegebharts) wrote :

Seems this bug still exists. I installed WICD for the same reason as 1wang, though on Ubuntu desktop 64 bit. I had the same problem last week, and the same thing fixed it (getting rid of the brackets in /etc/wicd/wired-settings.conf.)

Cerin (chrisspen) wrote :

Just happened for me on Ubuntu 10.04, after I removed all network-manager packages and installed wicd from the repo.

acari (acari-tuga) wrote :

I had the same problem... wicd was asking for password at startup

quick fix:

edit config file from terminal console:
gedit /etc/wicd/manager-settings.conf

search for:
sudo_app = 0

change to:
sudo_app = 1

=)

Barry Rueger (barry-rueger) wrote :

Same problem with a new Mint 15 install. Asks for password on start up, doesn't accept the root PW.

f0olyc0oly (yinkirsi) wrote :

@acari:

i dont have the manager-settings.conf

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions